Bug 238500 - "Install to disk" fails to format /boot partition
Summary: "Install to disk" fails to format /boot partition
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-30 21:22 UTC by Kai Blin
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 09:34:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kai Blin 2007-04-30 21:22:07 UTC
Description of problem:
Using the i586 KDE Live CD of F7t4, when using the Fedora Installer, it seems
like formatting the /boot partition fails.

The program will pop up an error message saying:
"""
Error mounting device sda1 as /boot: Invalid argument

This most likely means that this partition has not been formatted.

Press OK to reboot your system
"""

If you then press OK and reboot, the system will fail to boot.

How reproducible:

Once there's an MBR on the disk drive, I could always reproduce it, using
default options in the installer where possible.

Steps to Reproduce:
1. Boot KDE live CD, start Fedora Installer
2. Click through install using the default options, especially for partition setup
3. Error message pops up after installation
  
Actual results:

/boot seems not to be formatted, the machine fails to boot linux.

Expected results:

Linux should boot.

Additional info:
I was testing this install in a VMWare machine, not on real hardware.

Comment 1 Jeremy Katz 2007-04-30 21:33:34 UTC
Can you grab /tmp/anaconda.log from that point and attach it here?  I've done
lots of installs selecting the defaults and the right thing happens here..

Comment 2 Kai Blin 2007-05-01 09:34:00 UTC
Well, I'll be damned. I've managed to reproduce it three times yesterday
evening, but the three times I tried the install today it was working just fine.
There might be something weird going on, but I can't reproduce it anymore, so
I'm closing the bug. Sorry about the fuss.


Note You need to log in before you can comment on or make changes to this bug.