Bug 238510 - iwlwifi drivers fails to connect
iwlwifi drivers fails to connect
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 19:10 EDT by Nikos Charonitakis
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6.22.1-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 09:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this output repeats again and again propably during the endless disk activity (120.23 KB, application/octet-stream)
2007-04-30 19:14 EDT, Nikos Charonitakis
no flags Details

  None (edit)
Description Nikos Charonitakis 2007-04-30 19:10:06 EDT
Description of problem:
i m using fct4 with latest kernel 2.6.21-1.3116.fc7
I have strange problems with wireless network. At fist (straight after booting)
NetworkManager shows my network and reports connection established.
But i cant view any web page and my laptop's wireless led never comes up...
Trying to disconnect and connect back again never succeeds and additionally it
triggers endless hard disk activity.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nikos Charonitakis 2007-04-30 19:14:04 EDT
Created attachment 153843 [details]
this output repeats again and again propably during the endless disk activity
Comment 2 Simos Xenitellis 2007-05-01 01:28:45 EDT
Thanks for the report.

Could you please add the following information:
1. What is the brand and model of the laptop? (in case another user solved it
per laptop)
2. Which wireless card is this?
"lspci" should show the important details. It is a "miniPCI" (embedded to the
laptop) card, isn't it?
Comment 3 John W. Linville 2007-05-01 09:10:37 EDT
Also, please be sure to try the latest available rawhide kernels, including 
1.3122 (or later) when they become available tomorrow.  There have been a lot 
of important fixes to the iwlwifi driver very recently.
Comment 4 Nikos Charonitakis 2007-05-05 07:53:13 EDT
http://smolt.fedoraproject.org/show?UUID=dac1bfb6-b841-4744-953e-14593c289da3
dell 620

I m waiting for the new kernel to try.
In the mean time:
[root@localhost ~]# iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     Scan completed :
          Cell 01 - Address: 00:90:4C:7E:00:29
                    ESSID:"NETGEAR"
                    Mode:Master
                    Frequency:2.462 GHz
                    Signal level=-15 dBm  
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000000d5202b2188
                    Extra:bcn_int=100
                    Extra:capab=0x0401
Comment 5 Oleg Drokin 2007-05-14 14:59:28 EDT
In my situation using 2.6.21-1.3142 finally allowed me to connect to my AP using
WEP, though I still get some errors (I presume) in the messages:
ADDRCONF(NETDEV_UP): wlan0: link is not ready
hwcrypto disabled!
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:c0:02:7a:1a:a2
wlan0: RX authentication from 00:c0:02:7a:1a:a2 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:c0:02:7a:1a:a2
wlan0: RX AssocResp from 00:c0:02:7a:1a:a2 (capab=0x411 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
iwl3945: REPLY_ADD_STA failed
wlan0: duplicate address detected!

There is still another annoyance when using iwlwifi driver as opposed to ipw3945
driver from Intel, LED indicating that the wifi is in use does not work (stays
dark), with Intel driver it blinks when there is no connection (or reconnect) or
stays lit if there is connection/assotiation.
I have Dell Latitude D620 with
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
Comment 6 Nikos Charonitakis 2007-05-14 16:02:02 EDT
Same results from me. I did not try yet WEP/WAP though.
Also during booting i have to wait about one minute  when tries (and fails) to
get IP for wmaster0 with a message saying something like " SIOCSIFFLAGS not
supported" 
For this test i disabled SELinux and i m using NetworkManager.
Comment 7 John W. Linville 2007-06-01 16:39:13 EDT
Is this still a problem w/ the 1.3194 kernel?
Comment 8 Nikos Charonitakis 2007-06-01 19:33:25 EDT
You can close this bug. There are other problems (suspend-led off) but this is
resolved.
Comment 9 Robert Middleswarth 2007-06-03 12:17:16 EDT
I am getting the following dmsg.  My system worked fine under FC6 with ipw3945
drivers but when I did a clean upgrade to FC7 this is the messages I get during
boot.  An I fail to get a connection.

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c059adb6>] release_sock+0x12/0x9d
 [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
 [<c04808dc>] core_sys_select+0x218/0x2f3
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c045da36>] get_page_from_freelist+0x23b/0x2a5
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
iwl3945: Error sending REPLY_SCAN_CMD: time out after 500ms.
Comment 10 Hans de Goede 2007-06-10 07:49:50 EDT
Closing as per comment 8.

Robbert, there is an F7 kernel-update candidate available here:
http://people.redhat.com/davej/kernels/Fedora/fc7/RPMS.kernel/

Which amongst other things contains various fixes to the iwl3945 driver. Please
try this kernel and report back how it works for you.

Always be carefull when testing new kernels. Use rpm -ivh to install the new
kernel besides your current one so that you can always boot back into the old
kernel.

If that doesn't work please file a new bug for your problem.
Comment 11 John W. Linville 2007-07-13 11:52:25 EDT
Please try the kernels from here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=10941

Do they work any better for you?
Comment 12 Nikos Charonitakis 2007-07-22 12:20:04 EDT
I tried a new kernel from official updates (2.6.22.1-27.fc7)and now nothing works.
NetworkManager can't do any connection to wireless access point. Even
system-config-network seems that is not aware of any wireless device...
So, now i use kernel-2.6.21-1.3228.fc7 which is working (without led, and within
shorter distances compared to fc6-freshrpms's iwp3945 driver)
Comment 13 Hans de Goede 2007-07-22 14:07:44 EDT
Nikos,

These new kernels need the latest firmware, that should help!

Note You need to log in before you can comment on or make changes to this bug.