Bug 238530 - Intel Wireless 3945ABG not working in FC7 Test 4
Intel Wireless 3945ABG not working in FC7 Test 4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 02:08 EDT by Kyaw AM
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 11:00:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyaw AM 2007-05-01 02:08:29 EDT
Description of problem:
Error Message "SIOCSIFFLAGS: Operation not supported
Failed to bring up wmaster0."
When trying to activate wireless network in network configuration.
Wireless Card: Intel PRO/Wireless 3945ABG in HP dv2000 laptop

running iwconfig shows:

wmaster0 no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 22 of Wireless
Extension, while this program supports up to version 20.
Some thing may be broken...

wlan0   IEEE 802.11a ESSID:""
        Mode:Managed   Channel:0    Access Point: Not-Associated
        Retry min limit:7   RTS thr:off   Fragment thr=2346 B
        Encryption key:off
        Link Quality:0   Signal level:0   Noise level:0
        Rx invalid nwid:0   Rx invalid crypt:0   Rx invalid frag:0
        Tx excessive retries:0   Invalid misc:0    Missed beacon:0


Version-Release number of selected component (if applicable):
Fedora 7 Test 4

How reproducible:


Steps to Reproduce:
1. Install FC7 Test 4
2. System > Administration > Network
3. Activate wmaster0 network device (iwp3945)
  
Actual results:
Error Message "SIOCSIFFLAGS: Operation not supported
Failed to bring up wmaster0."

Expected results:
?

Additional info:
Comment 1 Christopher Aillon 2007-05-01 13:12:37 EDT
This is more likely an issue with the kernel drivers.
Comment 2 Doncho N. Gunchev 2007-05-01 15:25:34 EDT
My hardware profile is ebf36068-3809-426c-ade0-d0c531b5b402, Acer Aspire 6510 
laptop. I got iwlwifi to connect with wpa2, but no traffic got in/out with 
kernel-2.6.21-1.3116, now downloading 3123...
I would also like to mention that removing iwlwifi before hibernation is 
Comment 3 Doncho N. Gunchev 2007-05-01 15:26:28 EDT
  My hardware profile is ebf36068-3809-426c-ade0-d0c531b5b402, Acer Aspire 
6510 laptop. I got iwlwifi to connect with wpa2, but no traffic got in/out 
with kernel-2.6.21-1.3116, now downloading 3123...
  I would also like to mention that I had to remove iwlwifi before hibernation 
in order to have the system resume afterwards.
Comment 4 John W. Linville 2007-05-02 16:23:33 EDT
Does 3123 work better for you?
Comment 5 Doncho N. Gunchev 2007-05-03 04:35:08 EDT
It worked an hour yesterday with wpa2. I'm getting the following messages in the
log (2.6.21-1.3123.fc7 and 2.6.21-1.3125.fc7):

04:54:00 NetworkManager: <info>  wlan0: Device is fully-supported using driver
'iwlwifi'.
04:54:00 NetworkManager: <info>  nm_device_init(): waiting for device's worker
thread to start
04:54:01 NetworkManager: <info>  nm_device_init(): device's worker thread
started, continuing.
04:54:02 NetworkManager: <info>  Now managing wireless (802.11) device 'wlan0'.
04:54:02 NetworkManager: <info>  Deactivating device wlan0.

and in the same time:

04:53:57 kernel: =============================================
04:53:57 kernel: [ INFO: possible recursive locking detected ]
04:53:57 kernel: 2.6.21-1.3125.fc7 #1
04:53:57 kernel: ---------------------------------------------
04:53:58 kernel: NetworkManager/2536 is trying to acquire lock:
04:53:58 kernel:  (&dev->_xmit_lock){-...}, at: [<f8a8285e>]
ieee80211_set_multicast_list+0x46/0x167 [mac80211]
04:53:58 kernel:
04:53:58 kernel: but task is already holding lock:
04:53:59 kernel:  (&dev->_xmit_lock){-...}, at: [<c05b6b89>] dev_mc_upload+0x14/0x3c
04:54:00 kernel:
04:54:00 kernel: other info that might help us debug this:
04:54:01 kernel: 2 locks held by NetworkManager/2536:
04:54:01 kernel:  #0:  (rtnl_mutex){--..}, at: [<c0614e3a>] mutex_lock+0x21/0x24
04:54:02 kernel:  #1:  (&dev->_xmit_lock){-...}, at: [<c05b6b89>]
dev_mc_upload+0x14/0x3c
04:54:02 kernel:
04:54:02 kernel: stack backtrace:
04:54:02 kernel:  [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
04:54:02 kernel:  [<c04067ad>] show_trace+0x12/0x14
04:54:02 kernel:  [<c0406831>] dump_stack+0x16/0x18
04:54:02 kernel:  [<c04420a5>] __lock_acquire+0x11f/0xba4
04:54:02 kernel:  [<c0442f1c>] lock_acquire+0x56/0x6f
04:54:02 kernel:  [<c0616109>] _spin_lock+0x2b/0x38
04:54:02 kernel:  [<f8a8285e>] ieee80211_set_multicast_list+0x46/0x167 [mac80211]
04:54:02 kernel:  [<c05b6a5c>] __dev_mc_upload+0x20/0x22
04:54:02 kernel:  [<c05b6b9c>] dev_mc_upload+0x27/0x3c
04:54:02 kernel:  [<c05b4e04>] dev_open+0x47/0x66
04:54:02 kernel:  [<c05b374d>] dev_change_flags+0x51/0xf1
04:54:02 kernel:  [<c05bbb38>] rtnl_setlink+0x265/0x37d
04:54:02 kernel:  [<c05bb14a>] rtnetlink_rcv_msg+0x1bb/0x1de
04:54:02 kernel:  [<c05c77e9>] netlink_run_queue+0x65/0xd1
04:54:02 kernel:  [<c05baf45>] rtnetlink_rcv+0x29/0x42
04:54:02 kernel:  [<c05c7b87>] netlink_data_ready+0x15/0x56
04:54:02 kernel:  [<c05c6c59>] netlink_sendskb+0x1f/0x37
04:54:02 kernel:  [<c05c7544>] netlink_unicast+0x1ab/0x1c5
04:54:02 kernel:  [<c05c7b66>] netlink_sendmsg+0x271/0x27d
04:54:02 kernel:  [<c05aac27>] sock_sendmsg+0xe7/0x104
04:54:03 kernel:  [<c05aad95>] sys_sendmsg+0x151/0x1af
04:54:03 kernel:  [<c05abd91>] sys_socketcall+0x220/0x241
04:54:03 kernel:  [<c0405078>] syscall_call+0x7/0xb
04:54:03 kernel:  =======================

(I removed the date and the machine name)
  It's usable now. Knetworkmanager shows 100% signal strength all the time.
Compared to ipw3945 I think it looses more packets, but that's just a feeling.
After resume or when I turn the wireless kill switch on/off I have to remove the
module and insert it back to get it working again. If the connection is lost the
same procedure is required.
  On the bright side, iwlwifi connects at once, while ipw3945 I have to type my
key with it several times sometimes.
Comment 6 John W. Linville 2007-05-03 11:00:30 EDT
That locking message is actually harmless and can be ignored.  There is a 
patch forthcoming that will eliminate it.

I'm going to close this one.  NetworkManager not working is probably worth a 
separate bug...?
Comment 7 Kyaw AM 2007-05-03 11:02:21 EDT
I tried ipw3945, and the wifi could connect to open access point, but when tried
to connect to WEP, the net manager keep asking the passphrase.
Comment 8 Doncho N. Gunchev 2007-05-07 01:35:52 EDT
With kernel-2.6.21-1.3141.fc7 iwl3945 (whatever the previous test kernel version
was, it was killing the machine instantly) works much better (faster) for me
/wpa2/. The only problem is that sometimes at remove/insert something eats the
whole CPU or completely freezes the machine (I have messages from that). The
knetworkmanager related problems are now gone (I see proper signal levels).
Should I fill a new bug report or it is a known problem (rmmod/insmod problem)?

Note You need to log in before you can comment on or make changes to this bug.