Bug 238537 - rt2x00 driver lockdep spew when inserting card
rt2x00 driver lockdep spew when inserting card
Status: CLOSED DUPLICATE of bug 235956
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 04:27 EDT by François Kooman
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 09:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Kooman 2007-05-01 04:27:25 EDT
Description of problem:
It appears NetworkManager triggers some problem with the rt2x00 driver

Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3116.fc7
NetworkManager-0.6.5-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. plugin the rt2x00 card
  
Actual results:

'oops' message:

pccard: CardBus card inserted into slot 1
Loading module: rt2x00lib - CVS (N/A) by http://rt2x00.serialmonkey.com.
Loading module: rt2500pci - CVS (N/A) by http://rt2x00.serialmonkey.com.
PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:06:00.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
PCI: Setting latency timer of device 0000:06:00.0 to 64
wmaster0: Selected rate control algorithm 'simple'

=================================
[ INFO: inconsistent lock state ]
2.6.21-1.3116.fc7 #1
---------------------------------
inconsistent {hardirq-on-W} -> {in-hardirq-R} usage.
NetworkManager/2396 [HC1[1]:SC0[0]:HE0:SE1] takes:
 (dev_base_lock){-.??}, at: [<c05b5760>] dev_get_by_index+0x10/0x33
{hardirq-on-W} state was registered at:
  [<c04423ce>] __lock_acquire+0x448/0xba4
  [<c0442f1c>] lock_acquire+0x56/0x6f
  [<c061623b>] _write_lock_bh+0x30/0x3d
  [<c05b3362>] register_netdevice+0x278/0x300
  [<c05b46f5>] register_netdev+0x40/0x4d
  [<c075959c>] loopback_init+0xd/0xf
  [<c073c699>] init+0x1f1/0x2d6
  [<c0405cd3>] kernel_thread_helper+0x7/0x10
  [<ffffffff>] 0xffffffff
irq event stamp: 21896
hardirqs last  enabled at (21895): [<c047a8cb>] __kmalloc_track_caller+0xd3/0xf3
hardirqs last disabled at (21896): [<c0405a50>] common_interrupt+0x24/0x34
softirqs last  enabled at (21888): [<c042c014>] __do_softirq+0xdc/0xe2
softirqs last disabled at (21869): [<c0407420>] do_softirq+0x61/0xd0

other info that might help us debug this:
1 lock held by NetworkManager/2396:
 #0:  (rtnl_mutex){--..}, at: [<c0614eba>] mutex_lock+0x21/0x24

stack backtrace:
 [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
 [<c04067ad>] show_trace+0x12/0x14
 [<c0406831>] dump_stack+0x16/0x18
 [<c0440eb5>] print_usage_bug+0x141/0x14b
 [<c0441699>] mark_lock+0x18d/0x419
 [<c0442304>] __lock_acquire+0x37e/0xba4
 [<c0442f1c>] lock_acquire+0x56/0x6f
 [<c06162ee>] _read_lock+0x2b/0x38
 [<c05b5760>] dev_get_by_index+0x10/0x33
 [<d0ee5762>] ieee80211_beacon_get+0x16/0x3fa [mac80211]
 [<d0ecb3ee>] rt2500pci_interrupt+0x64/0x133 [rt2500pci]
 [<c0458b6e>] handle_IRQ_event+0x1a/0x46
 [<c045a07b>] handle_level_irq+0x90/0xd9
 [<c0407540>] do_IRQ+0xb1/0xd9
 [<c0405a5a>] common_interrupt+0x2e/0x34
 [<c05b4deb>] dev_open+0x2e/0x66
 [<c05b374d>] dev_change_flags+0x51/0xf1
 [<c05bbb38>] rtnl_setlink+0x265/0x37d
 [<c05bb14a>] rtnetlink_rcv_msg+0x1bb/0x1de
 [<c05c77e9>] netlink_run_queue+0x65/0xd1
 [<c05baf45>] rtnetlink_rcv+0x29/0x42
 [<c05c7b87>] netlink_data_ready+0x15/0x56
 [<c05c6c59>] netlink_sendskb+0x1f/0x37
 [<c05c7544>] netlink_unicast+0x1ab/0x1c5
 [<c05c7b66>] netlink_sendmsg+0x271/0x27d
 [<c05aac27>] sock_sendmsg+0xe7/0x104
 [<c05aad95>] sys_sendmsg+0x151/0x1af
 [<c05abd91>] sys_socketcall+0x220/0x241
 [<c0405078>] syscall_call+0x7/0xb
 =======================


Expected results:

No 'oops'

Additional info:

System profile:
http://smolt.fedoraproject.org/show?UUID=7249536a-feda-40cf-8407-917fbc02aa9a
Comment 1 John W. Linville 2007-05-01 09:22:01 EDT

*** This bug has been marked as a duplicate of 235956 ***

Note You need to log in before you can comment on or make changes to this bug.