Bug 238572 - pidgin: symbol lookup error: pidgin: undefined symbol: purple_core_migrate
pidgin: symbol lookup error: pidgin: undefined symbol: purple_core_migrate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 11:26 EDT by James Laska
Modified: 2013-09-02 02:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:14:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2007-05-01 11:26:45 EDT
# RPM pidgin-2.0.0-0.36.beta7.fc7.i386

$ pidgin 
pidgin: symbol lookup error: pidgin: undefined symbol: purple_core_migrate

> ldd -r /usr/bin/pidgin | grep "undefined"
undefined symbol: purple_imgstore_ref_by_id     (/usr/bin/pidgin)
undefined symbol: purple_buddy_icons_set_account_icon   (/usr/bin/pidgin)
undefined symbol: purple_imgstore_add_with_id   (/usr/bin/pidgin)
undefined symbol: purple_imgstore_unref_by_id   (/usr/bin/pidgin)
undefined symbol: purple_imgstore_find_by_id    (/usr/bin/pidgin)
undefined symbol: purple_buddy_icon_get_extension       (/usr/bin/pidgin)
undefined symbol: purple_core_migrate   (/usr/bin/pidgin)
undefined symbol: purple_buddy_icons_has_custom_icon    (/usr/bin/pidgin)
undefined symbol: purple_buddy_icons_find_account_icon  (/usr/bin/pidgin)
undefined symbol: purple_buddy_icons_find_custom_icon   (/usr/bin/pidgin)
undefined symbol: purple_buddy_icons_set_custom_icon    (/usr/bin/pidgin)

Looks like we should be linking against /usr/lib/libpurple.so.0 but that linkage
does not appear to have been made?
Comment 1 Luke Schierer 2007-05-01 11:29:59 EDT
does running ldconfig as root fix this?
Comment 2 James Laska 2007-05-01 11:42:26 EDT
> does running ldconfig as root fix this?

No, it does not help.  I believe this is a case of symbols changing in libpurple.

pidgin is correctly linking against libpurple:

$ ldd /usr/bin/pidgin  | grep purple
  libpurple.so.0 => /usr/lib/libpurple.so.0 (0x00683000)

However, libpurple isn't exporting the symbols noted in comment#0 any longer. 
For example... going through the list of undefined symbols above I see they are
no longer provided by libpurple.

# purple_imgstore_ref_by_id
$ strings /usr/lib/libpurple.so.0 | grep purple_imgstore_ref_by_id

# Looking at all the symbols noted in comment#0 ...
$ ldd -r /usr/bin/pidgin 2>&1 | grep undefined | while read LINE ; do set --
$LINE; SYMBOL=$3; echo -n " - $SYMBOL - "; strings /usr/lib/libpurple.so.0 |
grep -q $SYMBOL && echo FOUND || echo MISSING; done
 - purple_imgstore_ref_by_id - MISSING
 - purple_buddy_icons_set_account_icon - MISSING
 - purple_imgstore_add_with_id - MISSING
 - purple_imgstore_unref_by_id - MISSING
 - purple_imgstore_find_by_id - MISSING
 - purple_buddy_icon_get_extension - MISSING
 - purple_core_migrate - MISSING
 - purple_buddy_icons_has_custom_icon - MISSING
 - purple_buddy_icons_find_account_icon - MISSING
 - purple_buddy_icons_find_custom_icon - MISSING
 - purple_buddy_icons_set_custom_icon - MISSING
Comment 3 Stu Tomlinson 2007-05-01 11:55:10 EDT
What version of libpurple do you have installed?
Comment 4 James Laska 2007-05-01 12:04:40 EDT
Oops, sorry, neglected to include that in the first post.

libpurple-2.0.0-0.34.beta7devel.fc7.i386
Comment 5 Stu Tomlinson 2007-05-01 12:55:53 EDT
If you update to libpurple-2.0.0-0.36.beta7.fc7.i386 this will be fixed
Comment 6 Warren Togami 2007-05-01 13:14:39 EDT
We had to remove the Epoch at upstream's request.  You may upgrade with
--oldpackage or simply remove the packages before a reinstall.
Comment 7 James Laska 2007-05-01 13:57:18 EDT
That did the trick ... thanks!

Note You need to log in before you can comment on or make changes to this bug.