Bug 238597 - update CIFS client to 1.48aRH
update CIFS client to 1.48aRH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
: FutureFeature
: 224476 227973 (view as bug list)
Depends On:
Blocks: 222082
  Show dependency treegraph
 
Reported: 2007-05-01 14:28 EDT by Jeff Layton
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:48:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch -- update RHEL5 CIFS code to 1.48a (155.09 KB, patch)
2007-05-01 14:35 EDT, Jeff Layton
no flags Details | Diff
patch -- update RHEL5 CIFS code to 1.48aRH (155.07 KB, patch)
2007-05-07 12:44 EDT, Jeff Layton
no flags Details | Diff
patch -- delta from upstream tarball (2.06 KB, patch)
2007-06-07 12:14 EDT, Jeff Layton
no flags Details | Diff
tarball with backport of 1.48 for older kernels (240.10 KB, application/octet-stream)
2007-06-07 12:16 EDT, Jeff Layton
no flags Details

  None (edit)
Description Jeff Layton 2007-05-01 14:28:26 EDT
This is a tracking BZ for tracking the update of the CIFS client code to 1.48a.
Given that that's how CIFS updates have generally been handled in the past, it's
probably best to continue that in RHEL5 as well.
Comment 2 Jeff Layton 2007-05-01 14:35:48 EDT
Created attachment 153882 [details]
patch -- update RHEL5 CIFS code to 1.48a

This patch updates the RHEL5 CIFS code to 1.48a. It should apply cleanly on top

of 2.6.18-17.el5. Cursory testing indicates that it works as expected. Still
working on more in-depth testing...
Comment 3 RHEL Product and Program Management 2007-05-01 14:44:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Jeff Layton 2007-05-07 12:44:29 EDT
Created attachment 154279 [details]
patch -- update RHEL5 CIFS code to 1.48aRH

This is essentially identical to the other patch, but I folded in the patch for
bug #227973, and customized the version string.
Comment 5 Jeff Layton 2007-05-07 14:33:19 EDT
Testing done so far:

Connectathon test against FC6 samba (both with and without unix extensions),
win2k and win2k3. All basic and general tests pass. Special tests fall down
about halfway through, but they do that as well on the prior kernel.

fsstress tests run against samba -- no problems

Also, basic "hello" world type testing on all different hosts. Worked fine.
Comment 8 Jeff Layton 2007-05-08 13:29:56 EDT
I also need to clarify, if you mount a samba server with unix extensions
enabled, all the connectathon tests pass. If you disable them or run against a
windows machine, then the special tests fail early on.
Comment 10 Jeff Layton 2007-05-09 09:41:53 EDT
*** Bug 224476 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Layton 2007-05-09 09:42:33 EDT
*** Bug 227973 has been marked as a duplicate of this bug. ***
Comment 12 Jeff Layton 2007-06-07 12:14:17 EDT
Created attachment 156476 [details]
patch -- delta from upstream tarball

This patch is the delta on top of Steve French's backport. It's a few small
changes to make this build correctly on RHEL5, and also contains a patch that
went upstream after 1.48 came out to force an anonymous mount when sec=none is
specified on the command line.
Comment 13 Jeff Layton 2007-06-07 12:16:15 EDT
Created attachment 156478 [details]
tarball with backport of 1.48 for older kernels

This tarball contains the backport of the 1.48 code to earlier kernels that
Steve French did. The patch is based on this tarball.
Comment 14 Steve Dickson 2007-06-08 06:50:11 EDT
Why is the 'RH'added the version?

-#define CIFS_VERSION   "1.47"
+#define CIFS_VERSION   "1.48aRH"

Comment 15 Jeff Layton 2007-06-08 06:54:29 EDT
I noticed that Steve F. had forgotten to bump the version number when he rolled
this tarball so I figured we should fix that up. Also since this code isn't
really the *exact* 1.48a code it would be good to distinguish it somehow.
Comment 16 Steve Dickson 2007-06-08 07:20:30 EDT
Well logically its the same... unless I miss something there are no 
additional bug fixes or features... but I guess its a non-issue
as long as continue to stamp 'RH' for now on... (i.e. keeping
it consistent) 
Comment 18 Don Zickus 2007-06-15 20:31:54 EDT
in 2.6.18-27.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 19 Akemi Yagi 2007-06-30 14:53:28 EDT
(In reply to comment #18)
> in 2.6.18-27.el5
> You can download this test kernel from http://people.redhat.com/dzickus/el5

I am a bit confused.  Test kernels in there DO NOT contain the patch reported in
Bug 224359.  Without this (224359) patch, RHEL5.x would be totally useless for
those affected (kernel crash).

Akemi
Comment 20 Akemi Yagi 2007-06-30 15:04:29 EDT
(In reply to comment #19)
> (In reply to comment #18)
> > in 2.6.18-27.el5
> > You can download this test kernel from http://people.redhat.com/dzickus/el5
> 
> I am a bit confused.  Test kernels in there DO NOT contain the patch reported in
> Bug 224359.  

Sorry, I spoke too soon.  It seems to have the patch I referred to.


Comment 24 Don Zickus 2007-07-13 13:47:08 EDT
need to put this in MODIFIED state for the errata tool.
QE note this bz is still active due to documentation issues
Comment 33 Mike Gahagan 2007-09-19 13:41:00 EDT
Confirmed the CIFS module has been updated to 1.48aRH in 2.6.18-47.el5
Comment 35 errata-xmlrpc 2007-11-07 14:48:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.