Bug 23860 - anaconda crashes trying to open upgrade.log
anaconda crashes trying to open upgrade.log
Status: CLOSED DUPLICATE of bug 13071
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-11 22:35 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-13 18:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-11 22:35:54 EST
I was attempting to upgrade from 6.2 to 7.0.1 (which I have on CD).

Traceback (innermost last):
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
  rc = self.todo.doInstall ()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1526, in doInstall
  self.instLog = open(self.instLogName, "w+")
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/tmp/upgrade.log'

Sorry, I don't know how to print the stack frame in Pdb.
If you tell me how, I can re-run the upgrade and give you the relevant variables.

My system is a bit of a mess -- it was not cleanly upgraded from 6.1 to 6.2 --
so this may be just my problem.

Thanks,
John
Comment 1 Michael Fulbright 2001-01-12 10:22:43 EST
Is /tmp a symlink on your system?
Comment 2 Need Real Name 2001-01-13 18:15:32 EST
Yes.  The relevant links (gotten from ls -ls) are as follows:

/tmp -> /var/tmp/
/usr/tmp -> ../var/tmp
/var/tmp (real directory)

I don't remember whether the 6.1 install had an option to do
this or whether I hacked it myself.  If the 6.1 install had
the option then I would have used it.

By the way, there is a further irregularity in the above list
that is not a typo:  the /tmp link does indeed have a trailing slash
on it and the /usr/tmp link really does not have the trailing slash.
(Although I can't guarantee that the /usr/tmp link did not
originally have a trailing slash, because I manually changed
that when I was trying to work around the bug).

Thanks a lot for looking at this so quickly!
John
Comment 3 Need Real Name 2001-01-17 10:51:55 EST
I removed the /tmp soft-link and the upgrade worked fine.

When I searched the bug database before reporting this bug,
I forgot to include resolved bugs.

I apologize for to wasting your time.

Thanks again,
John


*** This bug has been marked as a duplicate of 13071 ***

Note You need to log in before you can comment on or make changes to this bug.