This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 238603 - No wireless networks detected
No wireless networks detected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 15:09 EDT by Adam Huffman
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.21-1.3194
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-02 16:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -n (732 bytes, text/plain)
2007-05-02 19:22 EDT, Adam Huffman
no flags Details
Output of /var/log/dmesg (25.97 KB, text/plain)
2007-05-02 19:24 EDT, Adam Huffman
no flags Details
dmesg output (29.56 KB, text/plain)
2007-05-03 17:47 EDT, Adam Huffman
no flags Details
latest dmesg output (33.44 KB, text/plain)
2007-05-21 18:06 EDT, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2007-05-01 15:09:45 EDT
Description of problem:

With the latest kernel and wireless-tools no wireless networks are detected and
running 'iwlist scan' causes a segmentation fault.

Version-Release number of selected component (if applicable):

2.6.21-1.3116.fc7

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

No wireless networks detected.

Expected results:

My own network (and the other neighbouring networks) should be detected and I
should be able to choose one in NetworkManager.

Additional info:
Comment 1 John W. Linville 2007-05-01 15:54:01 EDT
Gonna need a bit more info.  Let's start with the output of running 'dmesg' 
and 'lspci -n'.
Comment 2 Adam Huffman 2007-05-02 19:22:56 EDT
Created attachment 154001 [details]
Output of lspci -n
Comment 3 Adam Huffman 2007-05-02 19:24:35 EDT
Created attachment 154002 [details]
Output of /var/log/dmesg
Comment 4 Adam Huffman 2007-05-02 19:27:05 EDT
I suppose I ran out of steam on this one.  Let me know what else would be useful.
Comment 5 Adam Huffman 2007-05-02 19:28:09 EDT
It's a Vaio SZ3.  Had pretty good results with the ipw3945 driver when running FC6.
Comment 6 John W. Linville 2007-05-03 10:58:19 EDT
Please try the latest kernels from here:

   http://people.redhat.com/davej/kernels/Fedora/

Do these work better for you?
Comment 7 Adam Huffman 2007-05-03 17:45:03 EDT
Same result, but at least there's more information.  I'm posting the dmesg
output as an attachment.  Looks like trouble with NetworkManager?
Comment 8 Adam Huffman 2007-05-03 17:47:03 EDT
Created attachment 154079 [details]
dmesg output
Comment 9 Adam Huffman 2007-05-03 17:49:34 EDT
That's with davej kernel 3125
Comment 10 Adam Huffman 2007-05-04 15:53:02 EDT
There still seems to be a problem with the latest kernel 3132.  No wireless
networks shown in NM, and a segmentation fault when I run iwlist scan:

iwlist[4096]: segfault at 0000000003636cf0 rip 0000000000401c9a rsp
00007fff5a8cd7b0 error 4
Comment 11 John W. Linville 2007-05-04 16:08:29 EDT
Running 3132 w/ NM right now, seems to work OK here.  I have had the driver 
die and had to 'modprobe -r iwl3945 ; modprobe iwl3945'.  Does that make 
things any better for you?

Can you configure wireless manually?  Does that work?
Comment 12 Adam Huffman 2007-05-04 16:27:24 EDT
I'll try that later on.  One weird thing with this kernel, having tried the
modprobe commands - ksoftirqd is now taking up 99% CPU time.
Comment 13 Adam Huffman 2007-05-05 11:24:38 EDT
Tried it on a different access point this morning and it was the same.  The
driver doesn't seem to be associating with any network.  I won't have the chance
to try any non-WPA networks until Tuesday.

Must admit I'm not quite sure how to configure WPA manually.
Comment 14 Adam Huffman 2007-05-07 15:25:30 EDT
Just tried with the latest davej kernel (3141) and the situation is still the
same:  NM doesn't detect any networks and trying to connect to my access point
manually doesn't work as the driver never associates.  Running 'iwlist scanning'
causes a segmentation fault.
Comment 15 Adam Huffman 2007-05-09 16:00:36 EDT
Ditto with 3144:  no networks detected with NM and manual setting doesn't work
either.
Comment 16 Adam Huffman 2007-05-15 16:35:51 EDT
Same effect with 2.6.21-1.3149.fc7:

iwconfig wlan0
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     IEEE 802.11a  ESSID:""  
          Mode:Managed  Frequency:5.17 GHz  Access Point: Not-Associated   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 17 John W. Linville 2007-05-15 16:39:17 EDT
Have you tried using the latest wireless-tools package?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=6573

Does "iwlist wlan0 scan" still segfault?
Comment 18 Adam Huffman 2007-05-15 16:42:41 EDT
Yes, still getting that segfault.  Just about to try that wireless-tools package.
Comment 19 Adam Huffman 2007-05-15 16:46:09 EDT
With that package (wireless-tools-28-3.fc7), "iwlist wlan0 scan" works and, once
I'd restarted the NM service, I could pick my own AP and authenticate to it.

Hurrsh.

Thanks for your persistence with this. 
Comment 20 Adam Huffman 2007-05-15 18:50:09 EDT
Meant to say 'hurrah' there.  However, I was speaking a little too soon.  While
wireless networks are detected now, the connection to my AP only lasts a minute
or so and then the laptop becomes very responsive, to the extent that I've had
to sync and reboot using Alt-SysRq twice now.  I suppose such iwlwifi problems
are probably well covered in other bugs, though.
Comment 21 John W. Linville 2007-05-17 14:35:03 EDT
Please try the lastest firmware (released 5/16/2007):
 
http://www.intellinuxwireless.org/iwlwifi/downloads/iwlwifi-3945-ucode-2.14.3.tgz

Does that work any better for you?
Comment 22 Adam Huffman 2007-05-17 15:36:08 EDT
That does seem better - the connection has been up for a few minutes now, though
I don't have the time to test more thoroughly tonight.
Comment 23 Adam Huffman 2007-05-21 18:06:25 EDT
Created attachment 155132 [details]
latest dmesg output

This is with kernel 2.6.21-1.3167.fc7 and the newer firmware, as requested in
the previous comment.
Comment 24 John W. Linville 2007-06-01 16:29:45 EDT
Is 1.3194 working better for you?  Can this be closed?
Comment 25 Adam Huffman 2007-06-02 16:01:49 EDT
Yes.  Networks are reliably detected now, though the operation of the driver is
still flaky (though I've referred to that in another bug report).

Note You need to log in before you can comment on or make changes to this bug.