Bug 238605 - Keyboard not working when resuming from suspend-to-disk
Keyboard not working when resuming from suspend-to-disk
Status: CLOSED DUPLICATE of bug 238407
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 15:15 EDT by Adam Huffman
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 01:45:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2007-05-01 15:15:21 EDT
Description of problem:

When I resumed after suspending a Vaio SZ3 to disk, the password window appeared
but I was unable to type anything.  Hence, I was unable to log back in to the
machine.

Version-Release number of selected component (if applicable):
2.6.21-1.3116.fc7

How reproducible:


Steps to Reproduce:
1. Suspend to disk
2. Resume
3.
  
Actual results:

Unable to enter user password.

Expected results:

Enter user password and login to the resumed session.

Additional info:
Comment 1 Andrew Bartlett 2007-05-07 01:02:22 EDT
I've seen the same on suspend to disk/RAM on an Thinkpad X60 (x86), with this
kernel.  Even an external USB keyboard doesn't work.  
Comment 2 Andrew Bartlett 2007-05-07 01:45:53 EDT
I'll note that when in this state, the power button and mouse both work. 
Selecting 'Switch User' also works, so it's not X that's the problem. 
Ctrl+Alt+F1 does not work.

Sadly there isn't an on-screen keyboard to painfully enter a password (and begin
debugging) with...

This is not consistant, but I'm pretty sure this is related to the iwlwifi
module or the wifi hardware, and a duplieate of #238407.  I think it leaves some
interupts off.

*** This bug has been marked as a duplicate of 238407 ***

Note You need to log in before you can comment on or make changes to this bug.