This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 238614 - keystore fails in tomcat
keystore fails in tomcat
Status: CLOSED DUPLICATE of bug 238613
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 15:58 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 16:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2007-05-01 15:58:42 EDT
Description of problem:

I was trying to enable a keystore in tomcat, and open https://localhost:8443
When I did this, I got this traceback in catalina.log:

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
1-May-07 2:34:36 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path: /usr/lib64/gcj-4.1.2
1-May-07 2:34:36 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
1-May-07 2:34:36 PM org.apache.tomcat.util.net.jsse.JSSESocketFactory getStore
SEVERE: Exception trying to load keystore /usr/share/tomcat5/.keystore
java.security.KeyStoreException: JKS
   at java.security.KeyStore.getInstance(libgcj.so.8rh)
   at java.security.KeyStore.getInstance(libgcj.so.8rh)
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.getKeystore(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.getKeyManagers(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.init(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(tomcat-util-5.5.20.jar.so)
   at org.apache.coyote.http11.Http11BaseProtocol.init(tomcat-http-5.5.20.jar.so)
   at
org.apache.catalina.connector.Connector.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardService.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardServer.initialize(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at java.lang.reflect.Method.invoke(libgcj.so.8rh)
   at org.apache.catalina.startup.Bootstrap.load(bootstrap.jar.so)
   at org.apache.catalina.startup.Bootstrap.main(bootstrap.jar.so)
Caused by: java.security.NoSuchAlgorithmException: Algorithm [JKS] of type
[KeyStore] from provider [gnu.javax.security.auth.callback.GnuCallbacks:
name=GNU-CALLBACKS version=2.1] is not found
   at gnu.java.security.Engine.getInstance(libgcj.so.8rh)
   at java.security.KeyStore.getInstance(libgcj.so.8rh)
   ...16 more
1-May-07 2:34:36 PM org.apache.coyote.http11.Http11BaseProtocol init
SEVERE: Error initializing endpoint
java.io.IOException: Exception trying to load keystore
/usr/share/tomcat5/.keystore: JKS
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.getKeystore(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.getKeyManagers(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.init(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(tomcat-util-5.5.20.jar.so)
   at
org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(tomcat-util-5.5.20.jar.so)
   at org.apache.coyote.http11.Http11BaseProtocol.init(tomcat-http-5.5.20.jar.so)
   at
org.apache.catalina.connector.Connector.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardService.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardServer.initialize(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at java.lang.reflect.Method.invoke(libgcj.so.8rh)
   at org.apache.catalina.startup.Bootstrap.load(bootstrap.jar.so)
   at org.apache.catalina.startup.Bootstrap.main(bootstrap.jar.so)
1-May-07 2:34:36 PM org.apache.catalina.startup.Catalina load
SEVERE: Catalina.start
LifecycleException:  Protocol handler initialization failed:
java.io.IOException: Exception trying to load keystore
/usr/share/tomcat5/.keystore: JKS
   at
org.apache.catalina.connector.Connector.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardService.initialize(catalina-5.5.20.jar.som4esmn.so)
   at
org.apache.catalina.core.StandardServer.initialize(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at org.apache.catalina.startup.Catalina.load(catalina-5.5.20.jar.som4esmn.so)
   at java.lang.reflect.Method.invoke(libgcj.so.8rh)
   at org.apache.catalina.startup.Bootstrap.load(bootstrap.jar.so)
   at org.apache.catalina.startup.Bootstrap.main(bootstrap.jar.so)

I tested this on rawhide, but the same failure seems to be occuring on FC-6:
http://forums.fedoraforum.org/forum/showthread.php?t=136981
Comment 1 Tom "spot" Callaway 2007-05-01 16:42:37 EDT

*** This bug has been marked as a duplicate of 238613 ***

Note You need to log in before you can comment on or make changes to this bug.