Bug 238621 - Menu icon is blank
Summary: Menu icon is blank
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-01 20:34 UTC by vfiend
Modified: 2007-11-30 22:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 16:17:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vfiend 2007-05-01 20:34:48 UTC
Description of problem: Pidgin's menu entry doesn't have an icon, it's blank.
This affects the default theme as well as other preinstalled icon themes.


Version-Release number of selected component (if applicable): 2.0.0-0.36.beta7.fc7

Comment 1 Warren Togami 2007-05-02 00:38:26 UTC
Where are you seeing this?  The pidgin in Applications -> Internet has a purple
icon for me.

Comment 2 vfiend 2007-05-02 01:40:30 UTC
Applications->Internet in an F7 Test 4 install which was updated to the latest
packages. I just tried a new user account and the icon is also blank there, I
also tried removing and reinstalling pidgin and libpurple. This is odd because
there seem to be icons under the hicolor icon directory, but they aren't being
used for some reason. I suppose if it works for other people it's a random
unsolvable bug on my end, it'll be blown away when I install F7 final anyway.

Comment 3 Stu Tomlinson 2007-05-02 02:19:36 UTC
I believe that this is a bug in the pidgin RPM that will be fixed in the next
update, but could you confirm that running the following commands as root fixes
this issue?:

touch --no-create /usr/share/icons/hicolor
gtk-update-icon-cache --quiet /usr/share/icons/hicolor

Comment 4 vfiend 2007-05-02 02:29:15 UTC
Yes, that fixed it, though I also had to kill gnome-panel to get it to show up
after that, for what it's worth.

Comment 5 sangu 2007-05-02 05:52:16 UTC
Please See :
http://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets/iconcache

$ rpm -ql pidgin | grep hicolor
/usr/share/icons/hicolor
/usr/share/icons/hicolor/16x16
/usr/share/icons/hicolor/16x16/apps
/usr/share/icons/hicolor/16x16/apps/pidgin.png
/usr/share/icons/hicolor/24x24
/usr/share/icons/hicolor/24x24/apps
/usr/share/icons/hicolor/24x24/apps/pidgin.png
/usr/share/icons/hicolor/32x32
/usr/share/icons/hicolor/32x32/apps
/usr/share/icons/hicolor/32x32/apps/pidgin.png
/usr/share/icons/hicolor/48x48
/usr/share/icons/hicolor/48x48/apps
/usr/share/icons/hicolor/48x48/apps/pidgin.png
/usr/share/icons/hicolor/scalable
/usr/share/icons/hicolor/scalable/apps
/usr/share/icons/hicolor/scalable/apps/pidgin.svg



Note You need to log in before you can comment on or make changes to this bug.