Bug 238632 - rt2500pci wireless card see as an ethernet card
rt2500pci wireless card see as an ethernet card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 17:24 EDT by Eric Tanguy
Modified: 2007-12-21 13:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 13:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Tanguy 2007-05-01 17:24:00 EDT
Description of problem:
my rt2500pci wireless card is viewed as an ethernet card in test4 live cd so i
can't use it to associate.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2007-05-02 07:47:04 EDT
what is the output of:
# /sbin/iwconfig

Maybe a firmware is missing to put that card operational?
Comment 2 Eric Tanguy 2007-05-02 10:40:47 EDT
This device works fine without any firmware. It works fine with networkmanager.
My problem is as my system is a desktop i don't want to use networkmanager and i
want to configure the network definitely using system-config-network. I will
post the output of iwconfig when i'll be back at home
Comment 3 Eric Tanguy 2007-05-02 16:25:44 EDT
# iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

But only eth0 and wmaster0 are seen in system-config-network
Comment 4 Eric Tanguy 2007-05-26 06:11:00 EDT
this problem seems to be solved using livecd RC2 (ie kernel 2.6.21-1.3194.fc7)
Comment 5 Eric Tanguy 2007-06-02 14:08:44 EDT
Now the wireless card is viewed in system-config-network and i achieve to put it
up but the network don't work. When i ping router : host unreachable.
If i use network manager the network work like a charm
Comment 6 John 2007-09-12 15:29:08 EDT
I've seen similar issues with the rt2500pci driver.  My network
has a Linksys access point & uses a 128 bit WEP key.  The network
does not reliably start up using ifup.  (I haven't been using
NetworkManager on that workstation.)  When it does come up, the
data rate is very low (~30 kib/s).  Even when the interface is
up, and appears to be working from the workstation's desktop,
remote access is intermittent.  HTTP and SSH connections ofter
only succeed for a short period (minutes to hours) after the
connection is raised, and then later timeout.  Outbound connections
often still work, and previously opened SSH connections from the
outside often stay up.  I haven't seen any correlations in this
behavior with dmesg output.  (Unfortunately, I'm not at the
workstation right now and SSH is not connecting.  I can provide
further diagnostic information later if requested.)
Comment 7 Eric Tanguy 2007-12-15 10:56:22 EST
For me this is solved. Could we close the bug ?

Note You need to log in before you can comment on or make changes to this bug.