Bug 238633 - /var/www/moodle/web/config.php overwritten on upgrade
Summary: /var/www/moodle/web/config.php overwritten on upgrade
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: moodle (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-01 21:32 UTC by Dan Young
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:51:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Young 2007-05-01 21:32:11 UTC
Description of problem:
/var/www/moodle/web/config.php contains the database configuration for Moodle.
It is being overwritten on upgrade.

Version-Release number of selected component (if applicable):
moodle-1.6.5-3.fc5

How reproducible:
every time

Steps to Reproduce:
1. Upgrade moodle
  
Actual results:
/var/www/moodle/web/config.php is overwritten with RPM default

Expected results:
Should get /var/www/moodle/web/config.php.rpmnew

Additional info:
Should be marked %config(noreplace)

Comment 1 Jerry James 2007-05-07 20:51:39 UTC
Thanks.  As it turns out, there are several other config.php files that need to
be marked %config(noreplace).  Fixed in moodle-1.6.5-4.{fc5,fc6} and
moodle-1.8-4.fc7.



Note You need to log in before you can comment on or make changes to this bug.