Bug 238634 - firmware-addon-dell: useless debuginfo package
Summary: firmware-addon-dell: useless debuginfo package
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firmware-addon-dell (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael E Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Patch, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-01 21:36 UTC by Ville Skyttä
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 20:31:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disable useless debuginfo package (711 bytes, patch)
2007-05-01 21:36 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2007-05-01 21:36:41 UTC
http://fedoraproject.org/wiki/Packaging/Debuginfo

firmware-addon-dell produces an empty debuginfo package.  Doesn't look like
there's any native code in it, so it could be just disabled, fix attached.

Comment 1 Ville Skyttä 2007-05-01 21:36:41 UTC
Created attachment 153897 [details]
Disable useless debuginfo package

Comment 2 Michael E Brown 2007-05-01 21:45:28 UTC
Thanks!

fix committed for next build.

because of F7 freeze, I had not planned on any new builds soon. This might not
go away until after F7 release.

Comment 3 Ville Skyttä 2007-05-01 22:29:21 UTC
Hmm, maybe I'm confused, but I saw a commit to firmware-tools which disables the
debuginfo package, not firmware-addon-dell which this bug is filed against.

However, firmware-tools was already noarch, so disabling the debuginfo package
in it is not necessary (except on EL3 where it's not noarch).  I did not see a
commit to firmware-addon-dell, which is noarch and is actually still producing
an empty debuginfo package per the sources in CVS's devel branch.

(Off topic: additionally, the sources for the 1.2.6 firmware-tools package in
CVS devel branch aren't in the CVS lookaside cache and the download URL gives a
404 not found.)

Comment 4 Ville Skyttä 2007-05-01 22:30:09 UTC
(In reply to comment #3)
> firmware-addon-dell, which is noarch

s/is noarch/is not noarch/


Comment 5 Michael E Brown 2007-05-01 22:44:14 UTC
Yeah, I misread. I've applied the same patch to firmware-addon-dell now. (will
commit later tonight after I have synced this to my devel tree)


Comment 6 Ville Skyttä 2007-07-28 15:10:09 UTC
Looks like this has not yet been built for devel/F8.  Any news?

Comment 7 Michael E Brown 2007-08-01 16:15:35 UTC
I have an update queued up. I'll try to push this update on Thursday.


Note You need to log in before you can comment on or make changes to this bug.