Bug 238640 - OProfile not generating samples?
OProfile not generating samples?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 18:48 EDT by Daryll
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 10:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2007-05-01 18:48:04 EDT
Fedora 7 test4
kernel: 2.6.21-1.3116.fc7
Core 2 Duo SMP

oprofile --init
oprofile --no-vmlinux
oprofile --start
run some regular stuff
oprofile --stop
opreport

opreport error: No sample file found: try running opcontrol --dump
or specify a session containing sample files

oprofile --dump

opreport error: No sample file found: try running opcontrol --dump
or specify a session containing sample files

The directory /var/lib/oprofile/samples/current is empty.
The oprofiled.log contains:
oprofiled started Tue May  1 15:39:26 2007
kernel pointer size: 4

The /dev/oprofile seems to be populated and /dev/oprofile/enable goes from 0 to
1 and back to 0 appropriately between --start and --stop.

I removed /root/.oprofile, so it was created in the default state.

Just no samples to be found.
Comment 1 Chuck Ebbert 2007-05-01 19:34:51 EDT
Please post contents of /proc/cpuinfo (just one CPU not all.)

Did this work with earlier kernels on this exact hardware?
Comment 2 Daryll 2007-05-01 19:42:03 EDT
Yes, it worked with the latest FC6 kernel. That's why I was so surprised when
nothing happened. :)

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T5500  @ 1.66GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni
monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3329.79
clflush size    : 64

It's a Core 2 Duo HP laptop.
Comment 3 Matthew Gregan [:kinetik] 2007-05-15 01:23:53 EDT
Benjamin LaHaise has posted an analysis and patch for this problem here:
http://lkml.org/lkml/2007/5/13/179
Comment 4 Dave Jones 2007-05-15 15:15:42 EDT
added this patch to CVS, will be in the next build.  
can you retest with kernel-2.6.21-1.3162.fc7 when it appears ?

it'll be at http://people.redhat.com/davej/kernels/Fedora/fc7/ in a few hours,
and hopefully in rawhide tomorrow.
Comment 5 Matthew Gregan [:kinetik] 2007-05-16 00:20:09 EDT
Thanks Dave!  Sampling works with kernel-2.6.21-1.3163.fc7.x86_64 on a Core 2
Duo E6400 running SMP.

Note You need to log in before you can comment on or make changes to this bug.