Bug 238657 - wireless-tools in rawhide broken for x86-64
wireless-tools in rawhide broken for x86-64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-05-01 23:32 EDT by Warren Togami
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 13:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a similar bt from my identical crash (5.05 KB, text/plain)
2007-05-02 14:33 EDT, das_deniz
no flags Details
as much as i can dig into it - hope it helps (2.53 KB, text/plain)
2007-05-02 15:13 EDT, das_deniz
no flags Details
first try (1.85 KB, patch)
2007-05-02 16:35 EDT, Christopher Aillon
no flags Details | Diff

  None (edit)
Description Warren Togami 2007-05-01 23:32:57 EDT
wireless-tools-28-2.fc7
kernel-2.6.21-1.3116.fc7

After upgrading to the new wireless tools and NetworkManager in today's rawhide,
ipw3945 on x86_64 stopped working.  I don't see any signs on the surface of what
went wrong, except this segfault:

Starting program: /sbin/iwlist eth0 scan
Warning: Driver for device eth0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

eth0      Scan completed :
          Cell 01 - Address: 5B:2E:58:BC:B0:11
                    ESSID:""
                    Protocol: 802.11bg

Program received signal SIGSEGV, Segmentation fault.
0x0000000000401c9a in print_scanning_info (skfd=6, ifname=0x7ffff8337c0b "eth0",
args=<value optimized out>, count=<value optimized out>) at iwlist.c:1101
1101          printf("                    Mode:%s\n",
(gdb) bt
#0  0x0000000000401c9a in print_scanning_info (skfd=6, ifname=0x7ffff8337c0b
"eth0", args=<value optimized out>, count=<value optimized out>) at iwlist.c:1101
#1  0x0000000000402493 in main (argc=<value optimized out>, argv=<value
optimized out>) at iwlist.c:1641
#2  0x00000038f5a1da24 in __libc_start_main () from /lib64/libc.so.6
#3  0x00000000004011b9 in _start ()
(gdb) bt full
#0  0x0000000000401c9a in print_scanning_info (skfd=6, ifname=0x7ffff8337c0b
"eth0", args=<value optimized out>, count=<value optimized out>) at iwlist.c:1101
        key = {0 '\0', 96 '`', 172 '�', 170 '�', 170 '�', 42 '*', 0 '\0', 0
'\0', 117 'u', 26 '\032', 105 'i', 9 '\t', 0 '\0', 0 '\0', 0 '\0', 0 '\0', 16
'\020', 124 '|', 51 '3', 
  248 '�', 255 '�', 127 '\177', 0 '\0', 0 '\0', 192 '�', 79 'O', 64 '@', 0 '\0',
0 '\0', 0 '\0', 0 '\0', 0 '\0', 216 '�', 106 'j', 32 ' ', 0 '\0', 0 '\0', 0
'\0', 0 '\0', 0 '\0', 
  166 '�', 205 '�', 96 '`', 245 '�', 56 '8', 0 '\0', 0 '\0', 0 '\0', 1 '\001', 0
'\0', 0 '\0', 0 '\0', 255 '�', 127 '\177', 0 '\0', 0 '\0', 0 '\0', 0 '\0', 0
'\0', 0 '\0', 0 '\0', 
  0 '\0', 0 '\0', 0 '\0'}
        wrq = {ifr_ifrn = {ifrn_name = "eth0", '\0' <repeats 11 times>}, u =
{name = "\020``\000\000\000\000\000�\t\000\000�\177\000", essid = {pointer =
0x606010, length = 2470, 
      flags = 0}, nwid = {value = 6316048, fixed = 0 '\0', disabled = 0 '\0',
flags = 0}, freq = {m = 6316048, e = 0, i = 0 '\0', flags = 0 '\0'}, sens =
{value = 6316048, 
      fixed = 0 '\0', disabled = 0 '\0', flags = 0}, bitrate = {value = 6316048,
fixed = 0 '\0', disabled = 0 '\0', flags = 0}, txpower = {value = 6316048, fixed
= 0 '\0', 
      disabled = 0 '\0', flags = 0}, rts = {value = 6316048, fixed = 0 '\0',
disabled = 0 '\0', flags = 0}, frag = {value = 6316048, fixed = 0 '\0', disabled
= 0 '\0', flags = 0}, 
    mode = 6316048, retry = {value = 6316048, fixed = 0 '\0', disabled = 0 '\0',
flags = 0}, encoding = {pointer = 0x606010, length = 2470, flags = 0}, power =
{value = 6316048, 
      fixed = 0 '\0', disabled = 0 '\0', flags = 0}, qual = {qual = 16 '\020',
level = 96 '`', noise = 96 '`', updated = 0 '\0'}, ap_addr = {sa_family = 24592, 
      sa_data = "`\000\000\000\000\000�\t\000\000�\177\000"}, addr = {sa_family
= 24592, sa_data = "`\000\000\000\000\000�\t\000\000�\177\000"}, param = {value
= 6316048, 
      fixed = 0 '\0', disabled = 0 '\0', flags = 0}, data = {pointer = 0x606010,
length = 2470, flags = 0}}}
        buffer = (unsigned char *) 0x7ffff8335b50 ""
        buflen = 4096
        range = {throughput = 27000000, min_nwid = 0, max_nwid = 0,
old_num_channels = 0, old_num_frequency = 0 '\0', event_capa = {69730384, 1024,
0, 0, 0, 0}, sensitivity = 0, 
  max_qual = {qual = 100 'd', level = 0 '\0', noise = 161 '�', updated = 7
'\a'}, avg_qual = {qual = 70 'F', level = 0 '\0', noise = 0 '\0', updated = 7
'\a'}, 
  num_bitrates = 12 '\f', bitrate = {1000000, 2000000, 5500000, 11000000,
6000000, 9000000, 12000000, 18000000, 24000000, 36000000, 48000000, 54000000, 0
<repeats 20 times>}, 
  min_rts = 0, max_rts = 2347, min_frag = 256, max_frag = 2346, min_pmp = 0,
max_pmp = 0, min_pmt = 0, max_pmt = 0, pmp_flags = 0, pmt_flags = 0, pm_capa =
0, encoding_size = {5, 13, 
    0, 0, 0, 0, 0, 0}, num_encoding_sizes = 2 '\002', max_encoding_tokens = 4
'\004', encoding_login_index = 0 '\0', txpower_capa = 0, num_txpower = 0 '\0',
txpower = {0, 0, 0, 0, 0, 
    0, 0, 0}, we_version_compiled = 22 '\026', we_version_source = 16 '\020',
retry_capa = 0, retry_flags = 0, r_time_flags = 0, min_retry = 0, max_retry = 0,
min_r_time = 0, 
  max_r_time = 0, num_channels = 24, num_frequency = 24 '\030', freq = {{m =
241200000, e = 1, i = 1 '\001', flags = 0 '\0'}, {m = 241700000, e = 1, i = 2
'\002', flags = 0 '\0'}, {
      m = 242200000, e = 1, i = 3 '\003', flags = 0 '\0'}, {m = 242700000, e =
1, i = 4 '\004', flags = 0 '\0'}, {m = 243200000, e = 1, i = 5 '\005', flags = 0
'\0'}, {m = 243700000, 
      e = 1, i = 6 '\006', flags = 0 '\0'}, {m = 244200000, e = 1, i = 7 '\a',
flags = 0 '\0'}, {m = 244700000, e = 1, i = 8 '\b', flags = 0 '\0'}, {m =
245200000, e = 1, i = 9 '\t', 
      flags = 0 '\0'}, {m = 245700000, e = 1, i = 10 '\n', flags = 0 '\0'}, {m =
246200000, e = 1, i = 11 '\v', flags = 0 '\0'}, {m = 518000000, e = 1, i = 36
'$', flags = 0 '\0'}, {
      m = 520000000, e = 1, i = 40 '(', flags = 0 '\0'}, {m = 522000000, e = 1,
i = 44 ',', flags = 0 '\0'}, {m = 524000000, e = 1, i = 48 '0', flags = 0 '\0'},
{m = 526000000, 
      e = 1, i = 52 '4', flags = 0 '\0'}, {m = 528000000, e = 1, i = 56 '8',
flags = 0 '\0'}, {m = 530000000, e = 1, i = 60 '<', flags = 0 '\0'}, {m =
532000000, e = 1, i = 64 '@', 
      flags = 0 '\0'}, {m = 574500000, e = 1, i = 149 '\225', flags = 0 '\0'},
{m = 576500000, e = 1, i = 153 '\231', flags = 0 '\0'}, {m = 578500000, e = 1, i
= 157 '\235', 
      flags = 0 '\0'}, {m = 580500000, e = 1, i = 161 '�', flags = 0 '\0'}, {m =
582500000, e = 1, i = 165 '�', flags = 0 '\0'}, {m = 0, e = 0, i = 0 '\0', flags
= 0 '\0'}, {m = 0, 
      e = 0, i = 0 '\0', flags = 0 '\0'}, {m = 0, e = 0, i = 0 '\0', flags = 0
'\0'}, {m = 0, e = 0, i = 0 '\0', flags = 0 '\0'}, {m = 0, e = 0, i = 0 '\0',
flags = 0 '\0'}, {m = 0, 
      e = 0, i = 0 '\0', flags = 0 '\0'}, {m = 0, e = 0, i = 0 '\0', flags = 0
'\0'}, {m = 0, e = 0, i = 0 '\0', flags = 0 '\0'}}, enc_capa = 15}
        has_range = 1
        tv = {tv_sec = 0, tv_usec = 0}
        timeout = 14750000
        __FUNCTION__ = "print_scanning_info"
#1  0x0000000000402493 in main (argc=<value optimized out>, argv=<value
optimized out>) at iwlist.c:1641
        skfd = 6
        dev = 0x7ffff8337c0b "eth0"
        cmd = 0x7ffff8337c10 "scan"
        args = (char **) 0x7ffff8335d40
        count = 0
        iwcmd = (const iwlist_cmd *) 0x404fc0
#2  0x00000038f5a1da24 in __libc_start_main () from /lib64/libc.so.6
No symbol table info available.
#3  0x00000000004011b9 in _start ()
No symbol table info available.
Comment 1 das_deniz 2007-05-02 14:33:09 EDT
Created attachment 153970 [details]
a similar bt from my identical crash

Linux t60p.local 2.6.21-1.3125.fc7 #1 SMP Tue May 1 18:08:03 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

$ rpm -qv wpa_supplicant wireless-tools NetworkManager iwlwifi-firmware
wpa_supplicant-0.5.7-2.fc7.x86_64
wireless-tools-28-2.fc7.x86_64
NetworkManager-0.6.5-2.fc7.x86_64
iwlwifi-firmware-2.14.1-4.noarch
Comment 2 Christopher Aillon 2007-05-02 15:04:45 EDT
looking.
Comment 3 das_deniz 2007-05-02 15:13:38 EDT
Created attachment 153975 [details]
as much as i can dig into it - hope it helps

SIOCGIWSCAN - kernel handling changed ? struct mismatch ? pls see attachment.
Comment 4 Christopher Aillon 2007-05-02 16:35:42 EDT
Created attachment 153989 [details]
first try

So, after looking at this, it almost looks like we should have been using _LEN
instead of _PK_LEN... In fact making that change certainly fixes the crash on
warren's machine.  But it still doesn't properly return SSIDs...
Comment 5 Christopher Aillon 2007-05-02 16:37:59 EDT
Dan, you did the backports of these patches initially... any idea here?
Comment 6 Warren Togami 2007-05-07 10:53:51 EDT
This change brought wireless on my laptop from working to broken.  Can we just
back this out for now?
Comment 7 Christopher Aillon 2007-05-07 11:05:39 EDT
This is on FC7Blocker.  It will be fixed one way or another.  There's no point
in doing it right now since we aren't getting rawhide updates anyway.  Have a
machine which reproduces this and dcbw is looking into it.  Will back it out
after rawhide updates start coming out again and there's no resolution in sight.
Comment 8 Will Woods 2007-05-11 14:08:43 EDT
People can get kernel and wireless-tools straight from koji, so there's plenty
of available testers. Can we get this patch backed out until/unless there's a
fix pending? This is causing a lot of spurious iwl3945 reports/discussion.
Comment 9 das_deniz 2007-05-11 14:16:00 EDT
if someone told me where / how to get the kernels and wireless-tools straight
from koji i'd be happy to test them.... back it out and people don't complain
about it - then it doesn't get fixed. bump the priority.
Comment 10 Will Woods 2007-05-11 14:25:15 EDT
We should have rawhide back in a day or two but in the meantime, we can still
get updated packages from koji. 

1) Go to: http://koji.fedoraproject.org/koji/
2) hit "Search", search for "kernel" or "wireless-tools". You'll find:
http://koji.fedoraproject.org/koji/packageinfo?packageID=8
http://koji.fedoraproject.org/koji/packageinfo?packageID=385

Unfortunately we can't really bump the priority any higher than "urgent
FC7Blocker". Release is 18 days away. Unless we have a fix that can be applied,
built, distributed, tested, and approved by then, reverting will solve the
problem and we can move this bug to F8Blocker.
Comment 11 das_deniz 2007-05-12 17:25:21 EDT
thank you very much Will, at this point i agree with you.

great site ... 

I did:

$ sudo rpm --force -Uvh Desktop/wireless-tools-28-1.fc6.x86_64.rpm 

and rebooted (with wpa_supplicant and NetworkManager on) and i'm submitting this
over my wireless.  the most recent update does nothing for functionality except
break it.

backing it out only looses a failed attempt to fix this driver for the x86_64
platform (a majority of laptops these days).

* Mon Apr 30 2007 Christopher Aillon <caillon@redhat.com> - 1:28-2
- Backport a few 64bit alignment fixes from the latest betas.

and i'm running on an x86_64 platform. this is a golden combination for me so
far as i've not had this much success with wifi 3945 on x86_64 and
NetworkManager + wpa till now:

$ rpm -qa wireless-tools NetworkManager iwlwifi\* wpa_\*
NetworkManager-0.6.5-2.fc7.x86_64
iwlwifi-firmware-2.14.1-4.noarch
wireless-tools-28-1.fc6.x86_64
wpa_supplicant-0.5.7-2.fc7.x86_64

$ uname -a
Linux t60p.local 2.6.21-1.3141.fc7 #1 SMP Sat May 5 20:31:10 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux
Comment 12 Jarod Wilson 2007-05-14 17:13:18 EDT
Couldn't ever get NM to see any wireless networks, even after updating to -3,
until I nuked the .i386 packages. Now I can see wireless networks, but like
others have reported, the system pretty much goes out to lunch after I try to
associate -- keyboard seems to do pretty much nothing in X, but the mouse works
enough to reboot the machine cleanly (eventually, sometimes requiring hitting
ctrl-alt-delete once I get out of X and into text mode, at which point the
keyboard sorta works again). So overall, better, I guess...
Comment 13 Warren Togami 2007-05-14 20:47:28 EDT
It sounds like you are referring to problems of the iwl3945 driver itself, not
this wireless-tools problem.
Comment 14 Sander Hoentjen 2007-05-15 01:36:35 EDT
with -2

# iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     Scan completed :
          Cell 01 - Address: 66:54:00:00:00:00
                    ESSID:""
Segmentation fault

with -3:

# iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     Scan completed :
          Cell 01 - Address: 00:11:F5:30:66:54
                    ESSID:"rtevents"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz
                    Signal level=-156 dBm  Noise level=-176 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=00000112bfbc7184

So for me this is better, on kernel 2.6.21-1.3142.fc7 x86_64, and the rt2x00
(rt2500) driver.
Comment 15 Hans de Goede 2007-05-15 02:42:50 EDT
The wireless-tools-28-3.fc7 works equally well for me as previous releases (iow
everything still works) this is with an prism54pci driven (prismII softmac) card
on an intel mobile pentium III
Comment 16 Will Woods 2007-05-17 13:19:59 EDT
The 64-bit patches should get revisited for a post-F7 update, but this bug is fixed.
Comment 17 Christopher Aillon 2007-05-17 18:36:42 EDT
Although technically, -2 is still broken and always will be which is what this
bug summary currently says.  Nothing I can do will change the fact that -2 broke
x86-64 and I can't actually fix the fact that -2 broke it without going back in
time.

Changing the summary to reflect intent.

Note You need to log in before you can comment on or make changes to this bug.