Bug 238658 - Xen kernel reboots workstation.
Xen kernel reboots workstation.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Juan Quintela
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 23:54 EDT by Glen Eustace
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.20.1-2952
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-10 15:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen Eustace 2007-05-01 23:54:59 EDT
Description of problem:

Xen kernel reboots my workstation soon after booting, std kernel works fine.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.20-1.2944.fc6 & kernel-2.6.20-1.2944.fc6

How reproducible:
Happens every time.

Steps to Reproduce:
1. Select Xen kernel from grub menu
2. Allow boot to complete
3. Wait a few minutes
  
Actual results:
Workstation reboots, last entry in the /var/log/messages

May  1 19:49:51 agree-6 kernel: no vm86_info: BAD
May  1 19:49:51 agree-6 kernel: swap_free: Bad swap file entry fffffff7


Expected results:
Selecting std kernel, system is stable and runs without error.

Additional info:
Fairly std config.  P4 processor, 2Gb RAM, IDE HDD
Comment 1 Hal Canary 2007-05-21 09:50:50 EDT
This happens to me after I updated from kernel-xen-2.6.19-1.2911.6.5.fc6 to
kernel-xen-2.6.20-1.2948.fc6.

I after it happened twice, I selected the old 2.6.19 version of the kernel from
the grub menu and have had no problem (my previous uptime on the 2.6.29-1.2911
had been several months).

I don't see any odd messages in the /var/log/messages files from before the
abrupt reboots.

$ cat /proc/cpuinfo | grep name
model name      : AMD Athlon(tm) XP 2200+

Comment 2 Eduardo Habkost 2007-06-04 09:06:27 EDT
This looks like the problem reported on bug #234008. Could you test kernel-xen 
2.6.20-1.2952.fc6, that is on updates-testing repository?
Comment 3 Glen Eustace 2007-06-10 15:57:05 EDT
2952 would appear to resolve the issue, thanks.

Note You need to log in before you can comment on or make changes to this bug.