Bug 238661 - "Could not demultiplex stream" error when trying to play /usr/share/wesnoth/sounds/fire.wav
Summary: "Could not demultiplex stream" error when trying to play /usr/share/wesnoth/s...
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: totem   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 05:21 UTC by Michael Wiktowy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 16:31:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fire.wav (19.02 KB, application/octet-stream)
2007-05-02 05:21 UTC, Michael Wiktowy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 437499 None None None Never

Description Michael Wiktowy 2007-05-02 05:21:52 UTC
Description of problem:
The following error occurred when trying to play
/usr/share/wesnoth/sounds/fire.wav in totem "An error occurred Could not
demultiplex stream". After this error occurred, no other files would play until
totem was restarted.

This wav file plays fine in Audacity.

Version-Release number of selected component (if applicable):
totem-2.18.1-3.fc7
wesnoth-1.2.4-1.fc7

How reproducible:
Always ... either by opening it through the totem menus or double clicking in
nautilus.

Steps to Reproduce:
1. Try to open /usr/share/wesnoth/sounds/fire.wav
  
Actual results:
The above error occurs

Expected results:
The wav file should play and not block future files from playing in the totem
session.

Additional info:

Comment 1 Michael Wiktowy 2007-05-02 05:21:52 UTC
Created attachment 153917 [details]
fire.wav

Comment 2 Bastien Nocera 2007-05-10 16:31:13 UTC
$ totem /usr/share/wesnoth/sounds/fire.wav 
** Message: Error: Could not demultiplex stream.
gstwavparse.c(1262): gst_wavparse_stream_headers (): /play/decodebin0/wavparse0:
Invalid WAV header (no fmt at start): LIST

Looks like the file isn't properly conformant.

I've filed this against GStreamer upstream at:
http://bugzilla.gnome.org/show_bug.cgi?id=437499


Note You need to log in before you can comment on or make changes to this bug.