Bug 238664 - hplip: faxing with low supplies causes bogus error
Summary: hplip: faxing with low supplies causes bogus error
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-05-02 05:59 UTC by Bernard Johnson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.7.4a-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 11:13:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to allow faxing with low supplies (1.57 KB, text/plain)
2007-05-02 05:59 UTC, Bernard Johnson
no flags Details

Description Bernard Johnson 2007-05-02 05:59:43 UTC
Description of problem:
hp-sendfax complains about low supplies when faxing, which is bogus because it
doesn't take any supplies to send a fax.

Version-Release number of selected component (if applicable):
hplip-1.7.2-3.fc6

How reproducible:
Always

Steps to Reproduce:
1. start with low supplies
2. attempt to send fax
3.
  
Actual results:
Transfering fax data...
error: Device is busy or in an error state (code=102). Please wait for the
device to become idle or clear the error and try again.

Expected results:
Send fax.

Additional info:
Patch attached.  It's a little hackish because there is no easy fix with the
current organization of error codes in the codebase.  Fortunately, it's small
and unobtrusive.

Original upstream report here:
http://article.gmane.org/gmane.comp.printing.hplip.devel/388

Comment 1 Bernard Johnson 2007-05-02 05:59:43 UTC
Created attachment 153918 [details]
patch to allow faxing with low supplies

Comment 2 Tim Waugh 2007-05-04 16:54:51 UTC
Fixed in CVS for FC-6 and F-7.

Comment 3 Bernard Johnson 2007-07-09 18:36:39 UTC
Also tested and working in hplip-1.7.4a-4.fc7


Note You need to log in before you can comment on or make changes to this bug.