Bug 238672 - update of httpd package stops HTTP daemon
Summary: update of httpd package stops HTTP daemon
Status: CLOSED DUPLICATE of bug 238045
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 07:55 UTC by Heiner Westphal
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 08:23:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Heiner Westphal 2007-05-02 07:55:50 UTC
Description of problem:
(Unattended) update to httpd 2.2.4-1.fc6 stops httpd without restarting it.

Version-Release number of selected component (if applicable):
2.2.4-1.fc6

How reproducible:
Did not try.

Steps to Reproduce:
1. erase httpd
2. install httpd 2.2.3
3. start httpd
4. access some pages (so modules get loaded, esp. mod_status)  
5. upgrade httpd to 2.2.4-*

Actual results:
httpd tries to reload and fails (service httpd reload), because the binary
receiving the HUP is the old one, but the modules are new.

Expected results:
httpd restarts and runs (service httpd restart).

Additional info:
/var/log/messages:
Apr 29 06:26:15 www.example.com Updated: httpd.i386 2.2.4-1.fc6
(Timestamp in localtime == GMT +2)

/var/log/httpd/error_log:
[Tue May 01 04:26:17 2007] [notice] SIGHUP received.  Attempting to restart
httpd: Syntax error on line 181 of /etc/httpd/conf/httpd.conf: Cannot load /etc/
httpd/modules/mod_status.so into server: /etc/httpd/modules/mod_status.so: undef
ined symbol: ap_get_server_description
(Timestamp in GMT)

Comment 1 Joe Orton 2007-05-02 08:23:14 UTC

*** This bug has been marked as a duplicate of 238045 ***


Note You need to log in before you can comment on or make changes to this bug.