Bug 238674 - i810 driver - cursor invisible after switching to textmode
i810 driver - cursor invisible after switching to textmode
Status: CLOSED DUPLICATE of bug 204599
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 04:10 EDT by Kaare Fiedler Christiansen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 08:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaare Fiedler Christiansen 2007-05-02 04:10:47 EDT
Description of problem:

Using i810 driver for Intel 82852/855GM Integrated Graphics Device (rev 02) on a
Dell Latitude D505.

After hibernate/resume, or after switching to textmode (Ctrl-Alt-F1) and back to
X (Ctrl-Alt-F7) the cursor is invisible. You can still use and move the mouse,
you can identify where it is by tooltips showing up, and windows becoming active
(with sloppy focus), but the cursor is invisible.

You can work around this bug, by setting the Option SWCursor, however this
disable direct rendering.

Possibly related: when switching between an external monitor and the LCD
display, the cursor graphics are mangled, with a ghost shadow of apparently
random graphics on the edge of the cursor.

Version-Release number of selected component (if applicable):

X version 1.3.0.0-3.fc7
kernel version 2.6.21-1.3116.fc7 (i686)

How reproducible:

Disappearing cursor: always
Mangled cursor: unknown

Steps to Reproduce:
1. Press Ctrl-Alt-F1
2. Press Ctrl-Alt-F7
  
Actual results:

Invisible cursor

Expected results:

Normal X behaviour
Comment 1 Adam Jackson 2007-05-11 17:14:19 EDT
What version of xorg-x11-drv-i810 is this with?
Comment 2 Kaare Fiedler Christiansen 2007-05-13 15:24:17 EDT
$ rpm -q xorg-x11-drv-i810
xorg-x11-drv-i810-2.0.0-2.fc7
Comment 3 Kaare Fiedler Christiansen 2007-05-24 16:41:20 EDT
Still doesn't work in xorg-x11-drv-i810-2.0.0-3.fc7

However, using the 'intel' driver rather than the 'i810' driver, it works perfectly.
Comment 5 Kaare Fiedler Christiansen 2007-07-10 10:00:46 EDT
Retried with xorg-x11-drv-i810-2.0.0.4.fc7. Still same result.
Comment 6 Kaare Fiedler Christiansen 2007-07-20 08:59:55 EDT

*** This bug has been marked as a duplicate of 204599 ***

Note You need to log in before you can comment on or make changes to this bug.