Bug 238675 - Please use 'ast' driver instead of 'vesa' driver
Summary: Please use 'ast' driver instead of 'vesa' driver
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ast (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 08:23 UTC by Y.C. Chen
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 18:30:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -q xorg-x11-drv-ast xorg-x11-drivers output srceen (24.20 KB, image/gif)
2007-05-03 03:24 UTC, boris lin
no flags Details
kudzu -p -c video (217 bytes, patch)
2007-05-04 02:06 UTC, boris lin
no flags Details | Diff
lspci -vn (2.95 KB, patch)
2007-05-04 02:08 UTC, boris lin
no flags Details | Diff

Description Y.C. Chen 2007-05-02 08:23:57 UTC
Description of problem:
Use 'vesa' as default in FC7 test3 after installed, please use 'ast' as 
default if use AST2000 (vendor id = 0x1a03, device id = 0x2000)

Comment 1 Adam Jackson 2007-05-02 21:35:37 UTC
Er, that should have worked in test3.  Please attach the output of:

rpm -q xorg-x11-drv-ast xorg-x11-drivers

Comment 2 boris lin 2007-05-03 03:24:45 UTC
Created attachment 154008 [details]
rpm -q xorg-x11-drv-ast xorg-x11-drivers output srceen

This attach file is output srceen

Comment 3 Y.C. Chen 2007-05-03 06:07:01 UTC
Dear sir,
I know the AST2000 driver had been included in FC7 already. Our concern is 
that after installed the FC7 using AST2000 VGA card, then the xorg config will 
set 'vesa' as default and not 'ast'. We hope FC7 installer could use 'ast' as 
default if AST2000 be detected. Maybe this issue not related to the component 
of xorg-x11-drv-ast, could you help to transfer to proper owner?

Regards,

Y.C. Chen

Comment 4 Adam Jackson 2007-05-03 18:21:00 UTC
ast is probably the right component.  The question is just why we're not
detecting it properly.

Can you also attach the output of:

lspci -vn

and

kudzu -p -c video

?

Comment 5 boris lin 2007-05-04 02:06:46 UTC
Created attachment 154093 [details]
kudzu -p -c video

This attach file is output result.

Comment 6 boris lin 2007-05-04 02:08:03 UTC
Created attachment 154094 [details]
lspci -vn

This attach file is output result.

Comment 7 boris lin 2007-05-04 02:17:47 UTC
Comment on attachment 154093 [details]
kudzu -p -c video

This result is already change VGA default setting.

Comment 8 Y.C. Chen 2007-05-18 03:03:44 UTC
Dir sir,
DO you have any update or need us supply more information?

Regards,

Y.C. Chen


Comment 9 Adam Jackson 2007-09-06 18:30:34 UTC
So in F7 and later, I think this is caused by a bug in anaconda.  The initial
xorg.conf is created by anaconda at install time, but it will only select among
those drivers that happen to be present in the anaconda stage2 image, and
-drv-ast was never added there.

In current anaconda, the X driver list for stage2 is populated by the
dependencies of the xorg-x11-drivers metapackage, so this should no longer be an
issue.  Please test installation with Fedora 8 test 2 (which should be released
in the next week or so) and verify that this is resolved for you.

Comment 10 Y.C. Chen 2007-09-07 02:06:36 UTC
We will try it on FC8 test2.
Thanks,

Y.C. Chen


Note You need to log in before you can comment on or make changes to this bug.