Bug 23869 - glide_drv.o not included
glide_drv.o not included
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 09:37 EST by Miguel Freitas
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 15:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miguel Freitas 2001-01-12 09:37:44 EST
Why don't you include glide_drv.o in XFree4 rpms?
It's a great driver to use as a second display with that old
voodoo1 and voodoo2 boards. Mandrake provides it in their
distro as XFree-glide package.
Comment 1 Mike A. Harris 2001-02-06 14:33:19 EST
Is it stable?  If so, how do I enable it (to save me the time looking
it up as I'm unfamiliar with glide cards).  Is it a #define in the Imake
files?
Comment 2 Miguel Freitas 2001-02-06 15:02:58 EST
It looks pretty stable for me. In fact, it uses a old glide lib specific
for voodoo rush/graphics that haven't seem major changes for a long time,
ie, it must not have any serious bugs.

I really hate these xfree86 Imake files, but it guess it can be enabled 
with #define HasGlide2 YES. I'm not sure however because I prefered to
install the mandrake rpm.

The user still have to download the libglide2x.so and make a symbolic
link as described in XFree86 documentation. But this is MUCH easier than
downloading the XFree86 source code and recompiling it. (Look at 
rpmfind.net resource "glide" for the library)

If you can, just compile glide_drv.o in XFree86 package, it won't hurt 
anybody. If someone wants to use it just say RTFM.
Comment 3 Mike A. Harris 2001-02-06 15:35:46 EST
If I enable this, it means that it is a supported configuration, and that
means that I must include Glide2 with the distro.  This would also make
XFree86 haul both glide libs into all XFree installs without reworking the
entire packaging process being used currently.  It is too late to do any
of these major changes at this time.  If it had been suggested a few months
ago it might have been possible, but not right now.  I will add the code
to the spec file though so as a compromise so that those willing to rebuild
XFree86 and acquire GLide 2 on their own can do so more easily.

In the future I plan on breaking out drivers into separate subpackages
perhaps, and then maybe we can add Glide2 if there appears enough interest.
No promises though.

Note You need to log in before you can comment on or make changes to this bug.