Bug 238709 - GATT pages must be uncacheable
GATT pages must be uncacheable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
athlon Linux
high Severity high
: ---
: ---
Assigned To: Chip Coldwell
Martin Jenner
:
: 247795 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 10:30 EDT by Chip Coldwell
Modified: 2010-10-22 10:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:48:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (1.29 KB, patch)
2007-05-02 10:31 EDT, Chip Coldwell
no flags Details | Diff
backport of upstream patch to RHEL-5 (704 bytes, patch)
2007-05-02 10:46 EDT, Chip Coldwell
no flags Details | Diff

  None (edit)
Description Chip Coldwell 2007-05-02 10:30:25 EDT
The pages that store the GART PTEs must be uncacheable.  The penalty for getting
this wrong is data corruption, see RHEL-4 bug 223238.

commit cf6387daf8858bdcb3e123034ca422e8979d73f1
Author: Joachim Deguara <joachim.deguara@amd.com>
Date:   Tue Apr 24 13:05:36 2007 +0200

    [PATCH] x86-64: make GART PTEs uncacheable
    
    This patches fixes the silent data corruption problems being seen using the
    GART iommu where 4kB of data where incorrect (seen mostly on Nvidia CK804
    systems).  This fix, to mark the memory regin the GART PTEs reside on as
    uncacheable, also brings the code in line with the AGP specification.
    
    Signed-off-by: Joachim Deguara <joachim.deguara@amd.com>
    Signed-off-by: Andi Kleen <ak@suse.de>
Comment 1 Chip Coldwell 2007-05-02 10:31:52 EDT
Created attachment 153953 [details]
upstream patch
Comment 2 Chip Coldwell 2007-05-02 10:46:51 EDT
Created attachment 153955 [details]
backport of upstream patch to RHEL-5
Comment 3 Chip Coldwell 2007-05-02 14:54:38 EDT
POSTed 02-May-2007
Comment 4 RHEL Product and Program Management 2007-05-02 17:22:26 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 5 Don Zickus 2007-05-09 14:25:10 EDT
in 2.6.18-18.el5
Comment 7 Mike Gahagan 2007-09-19 14:36:04 EDT
Confirmed the fix is in the -45.el5 kernel
Comment 9 errata-xmlrpc 2007-11-07 14:48:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html
Comment 10 Don Zickus 2008-01-24 15:31:59 EST
*** Bug 247795 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.