Bug 238716 - hplip cannot be rebuild on x86_64 when 32bit sane-backend-libs is installed
Summary: hplip cannot be rebuild on x86_64 when 32bit sane-backend-libs is installed
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 15:30 UTC by Karsten Hopp
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-04 17:20:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2007-05-02 15:30:40 UTC
Description of problem:
There's a missing -L/lib/lib64 somewhere:
creating libhplip-api.la
(cd .libs && rm -f libhplip-api.la && ln -s ../libhplip-api.la libhplip-api.la)
/bin/sh ./libtool --tag=CC --mode=link gcc  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic   -o libsane-hpaio.la -rpath /usr/lib64 -version-info 1:0:0
 libsane_hpaio_la-hpaio.lo libsane_hpaio_la-mfpdtf.lo libsane_hpaio_la-pml.lo
libsane_hpaio_la-scl.lo libsane_hpaio_la-io.lo libsane_hpaio_la-common.lo
libsane_hpaio_la-soap_stub.lo libhpip.la libhplip-api.la -lsane -lnetsnmp -lm
-lcups -lusb -lcrypto -lpthread 
gcc -shared  .libs/libsane_hpaio_la-hpaio.o .libs/libsane_hpaio_la-mfpdtf.o
.libs/libsane_hpaio_la-pml.o .libs/libsane_hpaio_la-scl.o
.libs/libsane_hpaio_la-io.o .libs/libsane_hpaio_la-common.o
.libs/libsane_hpaio_la-soap_stub.o -Wl,--whole-archive ./.libs/libhplip-api.a
-Wl,--no-whole-archive  -Wl,--rpath
-Wl,/home/build/rebuild/build/hplip-1.7.2-8.fc7.src.rpm/hplip-1.7.2/.libs
-Wl,--rpath -Wl,/usr/lib64 ./.libs/libhpip.so -lsane -lnetsnmp -lm -lcups -lusb
-lcrypto -lpthread  -m64 -mtune=generic -Wl,-soname -Wl,libsane-hpaio.so.1 -o
.libs/libsane-hpaio.so.1.0.0
/usr/bin/ld: skipping incompatible /usr/lib/libsane.so when searching for -lsane
/usr/bin/ld: cannot find -lsane

Version-Release number of selected component (if applicable):
hplip-1.7.2-8.fc7

Comment 1 Tim Waugh 2007-05-04 17:20:58 UTC
Looks like you don't have sane-backends-libs-devel.x86_64 installed.  It builds
fine in koji.


Note You need to log in before you can comment on or make changes to this bug.