Bug 238721 - After suspend/resume my exteternal monitor works, but internal doesn't
After suspend/resume my exteternal monitor works, but internal doesn't
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 11:47 EDT by Valent Turkovic
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 01:52:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (55.74 KB, text/plain)
2007-05-15 08:52 EDT, Valent Turkovic
no flags Details
the correct log this time :) (104.19 KB, text/plain)
2007-05-15 09:22 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2007-05-02 11:47:41 EDT
Description of problem:
My laptop goes to sleep if I'm away from the keyboard some time, which is great.
When I return I resume the laptop via power button. Eveything works great after
resume except my laptop screen which I can't turn on no mater what I do.

When I boot up I can switch between my laptop screen and external LCD monitor
but after resuming from suspend I can't do that via keyboard shortcuts Fn-F7 on
my IBM R52 laptop.

Version-Release number of selected component (if applicable):
I have Fedora Core 6 regularly updated.

How reproducible:
Every time. 

Steps to Reproduce:
1. Leave laptop to go to sleep or put it manually to suspend mode.
2. Resume form suspend/sleep via power button
3. Try to enable laptop screen via Fn-F7
  
Actual results:
Nothing happens when I press Fn-F7, external monitor works ok but if I need to
carry laptop somewhere it is not in working state and I need to do a restart in
order to power-up laptop monitor again!

Expected results:
Pressing Fn-F7 shuts down external monitor and turns-on laptop screen.

Additional info:
Comment 1 Adam Jackson 2007-05-11 16:51:43 EDT
Why on earth would this be a s-c-d bug?

Please attach /var/log/Xorg.0.log so I can see what video hardware you're using.
 But note that in general, BIOS hotkey switching for video outputs is never
likely to work.
Comment 2 Valent Turkovic 2007-05-15 08:52:14 EDT
Created attachment 154727 [details]
/var/log/Xorg.0.log

/var/log/Xorg.0.log
Comment 3 Valent Turkovic 2007-05-15 08:56:49 EDT
sorry this is a wrong log file... ignore
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=154727

I'll send a log file from the correct laptop.
Comment 4 Valent Turkovic 2007-05-15 09:22:00 EDT
Created attachment 154733 [details]
the correct log this time :)

the correct log this time :)

Ignore the previous log, I send it from the wrong laptop.
Comment 5 Valent Turkovic 2007-05-15 09:25:44 EDT
" But note that in general, BIOS hotkey switching for video outputs is never
likely to work."

That isn't the point.
I want to be able to resume from suspend and continue working. Now I can't
because when I resume the screen says dead.

And by attaching an external monitor I can see that everything works ok after
resume except the internal display on my IBM R52 laptop.

If this isn't a bug for you can you point me in the right direction?
Comment 6 Adam Jackson 2007-05-21 16:19:30 EDT
My point was merely that it can't possibly be a bug in system-config-display, as
that program has nothing to do with suspend.

I see you're using the i810 driver; does the intel driver work any better?
Comment 7 Valent Turkovic 2007-05-21 16:59:56 EDT
I'm confused... isn't i810 intel driver? Can you explain it a bit.

Also this bug is a clone of this bug here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208650

I found a fix for suspend/resume and it is explained here:
http://thinkwiki.org/wiki/Problem_with_display_remaining_black_after_resume#Solution_for_ThinkPads_with_ATI_graphic_chips_and_Intel_915.2F945GM

thank you.
Comment 8 Matěj Cepl 2007-12-10 04:22:49 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 9 Valent Turkovic 2007-12-19 17:21:04 EST
This issue isn't apparent on Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.