Bug 238725 - IPV4 'Treason uncloaked' message - hints at a more general kernel/net bug
IPV4 'Treason uncloaked' message - hints at a more general kernel/net bug
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
urgent Severity high
: ---
: ---
Assigned To: Anton Arapov
Martin Jenner
:
Depends On:
Blocks: 249237
  Show dependency treegraph
 
Reported: 2007-05-02 12:26 EDT by Martin Poole
Modified: 2014-06-18 04:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for treason warnings derived from upstream change (402 bytes, patch)
2007-05-02 12:26 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2007-05-02 12:26:02 EDT
Description of problem:

IPV4 networking stack emits the following type of messages occasionally

TCP: Treason uncloaked! Peer A.B.C.D:4138/80 shrinks window
2421420804:2421422264. Repaired.
TCP: Treason uncloaked! Peer E.F.G.H:5013/80 shrinks window 281635575:281635576.
Repaired.
TCP: Treason uncloaked! Peer I.J.K.L:38740/80 shrinks window
1393004015:1393005475. Repaired.

Version-Release number of selected component (if applicable):

kernel-2.6.9-55

How reproducible:

Tricky

Steps to Reproduce:
1. run networking and wait.
2.
3.
  
Actual results:


TCP: Treason uncloaked! Peer A.B.C.D:4138/80 shrinks window
2421420804:2421422264. Repaired.
TCP: Treason uncloaked! Peer E.F.G.H:5013/80 shrinks window 281635575:281635576.
Repaired.
TCP: Treason uncloaked! Peer I.J.K.L:38740/80 shrinks window
1393004015:1393005475. Repaired.

Expected results:

no logs.

Additional info:

Root cause has been identified and fixed upstream 

http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=2ad41065d9fe518759b695fc2640cf9c07261dd2
Comment 1 Martin Poole 2007-05-02 12:26:04 EDT
Created attachment 153967 [details]
patch for treason warnings derived from upstream change
Comment 2 RHEL Product and Program Management 2007-05-08 16:24:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2007-05-31 05:22:16 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 4 Jason Baron 2007-06-28 15:51:26 EDT
committed in stream U6 build 55.14. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 9 errata-xmlrpc 2007-11-15 11:25:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.