Bug 23873 - GPM Locks Console
GPM Locks Console
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 10:00 EST by Dave Lindquist
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 14:29:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Lindquist 2001-01-12 10:00:07 EST
An out of the box Red Hat 7.0 install worked with absolutely no problems.

However, since doing a recent "up2date -u", the gpm (console mouse 
services) component seems to "freeze" the console on the machine.  SSH 
connections work without any problem, but the console responds to one 
keystroke every five minutes or so.

I unfortunately can't remember if the up2date actually updated gpm, but 
the problem occurred on the first reboot after the update.

Stopping gpm immediately fixes the problem (the console is fully 
responsive).

Both keyboard and mouse are connected via PS2.

The mouse is a very generic Logitech 3-button (which has worked on all 
previous versions of RedHat and gpm without problem).

Testing hitting keys during the boot cycle shows normal responsiveness 
until gpm starts, at which point it immediately becomes unresponsive.

up2date -l shows "current" versions of everything installed.

This problem can be fixed by simply stopping gpm, but it would be nice to 
know if there is a true fix for this.

The machine is NOT running X-Windows.  The machine is a Celeron 533, 128M 
RAM.
Comment 1 Dave Lindquist 2001-01-12 10:03:05 EST
gpm is version 1.19.3-4
Comment 2 Preston Brown 2001-01-12 11:14:16 EST
We have not released gpm errata, so up2date cannot have caused you any problems.

Have you changed any BIOS settings or other things?

We have lots of these logitech ps/2 mice in house (I have one on the computer I
am using right now) and cannot duplicate the problem, so we are somewhat at an
impasse here.
Comment 3 Dave Lindquist 2001-01-12 14:29:24 EST
Nothing has changed in hardware or hardware configuration or BIOS.

I am 99% sure that there were no software changes (other than up2date).

The system worked fine (with the same configuration) with both RedHat 7.0 and 
6.2 prior to the up2date that seemed to cause the problem (for lack of anything 
else to blame ;-)

The mouse itself has worked without problem on RedHat 6.0, 6.1, 6.2 on other 
systems.

In any case, I can stop the problem by disabling gpm, so it isn't a huge 
problem. ;-)
Comment 4 Preston Brown 2001-01-31 17:35:03 EST
If someone else can replicate this problem, we will reopen the bug.  Otherwise,
my best guess is something might have gone slightly wrong with your hardware. 
But we can't really tell at this point.

Note You need to log in before you can comment on or make changes to this bug.