Bug 23876 - backspace does not delete
backspace does not delete
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 10:29 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-28 14:28:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-12 10:29:41 EST
Hi, 
I'm having trouble getting backspace key to 
work as expected. In almost every application
I've tried, Control-H does the job
but how do I get backspace to map that way?

I'm assuming that I will need to set up my
.inputrc file and my .xinitrc file. 

I just don't know the commands to put into
those files to get this to work.
In addition, Control-H does not work in the 
StarOffice word processor.

	Thanks,

	Paul R. Behmen
	pbehmen@yahoo.com
Comment 1 Bernhard Rosenkraenzer 2001-01-12 10:36:18 EST
I can't reproduce this (without a .inputrc or anything other than exec startkde
in .xinitrc).
Does this happen only in X, or on the console as well?
Which keyboard layout are you using?
Did you modify /etc/inputrc?

Comment 2 Need Real Name 2001-01-12 11:03:45 EST
The applications that I've seen this in are Netscape and StarOffice
word processor. In addition, the rxvt behaves similarly. In StarOffice
even control-H doesn't backspace and delete. In Netscape, control-H
performs the backspace and delete.

I'm running sawfish in gnome. In this netscape window that I'm typing
in (Xwindows-MOTIF, I assume) control-H does my backspace and
delete just fine. Pressing the backspace key doesn't do anything: the
cursor remains in the same spot. 
Here's my .inputrc that I was experimenting with:

"\C-?": delete-char
"\C-h": backward-delete-char

I got this off of redhat's site when I searched for backspace. It was in
the keyboard how-to section 5 . 
I tried the .xinitrc from that area but
it didn't work.  X would not start up because of problems with that 
.xinitrc file. Here's the .xinitrc that the keyboard how-to recommended:

xmodmap <<-EOF
keycode 22  =  BackSpace osfBackSpace
keycode107=Delete
EOF

#startyourwindowmanagerhere,forexample:
(fvwm)2>&1|tee/dev/tty/dev/console

sttysane
sttyerase^H
loadmap<<-EOF
keycode14=BackSpace
keycode111=Delete
EOF


Comment 3 Need Real Name 2001-01-12 12:04:56 EST
No I did not alter /etc/.inputrc .
Comment 4 Need Real Name 2001-01-18 10:34:00 EST
I added the /etc/.inputrc file and I still have a problem with backspace
performing delete.  Sorry for the delay in getting back.  I want backspace
to move the cursor one character to the left and erase the character it
moved over.
Summary: In "vi" called from an xterm window, backspace works.
In Netscape backspace doesn't work but control-h does the same function.
In StarOffice word processor, back space doesn't work and control-h doesn't
work either.
In emacs backspace doesn't work and control-h doesn't work either.
Help!
Comment 5 Bernhard Rosenkraenzer 2001-01-28 12:36:58 EST
We still can't reproduce this, but your current description indicates a problem
with either your X setup or the XFree86 keytables.
Which keyboard layout are you using?
Comment 6 Bernhard Rosenkraenzer 2001-01-28 12:37:45 EST
Reassigning to XFree86, that's where the keytables are.
Comment 7 Need Real Name 2001-01-28 14:28:39 EST
1) I am currently using an IBM keyboard with the US
layout. 
2) What is a keytable, how do I access it? Are there 
descriptions of this in any of the manuals?
3) Why would XFree86 setup my resources this way?
Is this something I did during installation?
4) Sorry for the confusion, but from the last comment are
you saying that this problem is being reassigned to
XFree86? How do I contact them and is there a support
group/channel for them so I can resolve this problem?
Many, Many Thanks!
Comment 8 Mike A. Harris 2001-04-02 12:46:02 EDT
You mentioned above you added "/etc/.xinputrc".  The file is /etc/inputrc with
no dot.  If you make a personal inputrc in your home directory it should
be ~/.inputrc

I cannot reproduce any of the problem you are having so it must be a local
configuration issue I think.

You might want to try our mailing lists for configuration help.

Note You need to log in before you can comment on or make changes to this bug.