Bug 238776 - X freakout / server lockup on resume with intel driver (i915)
X freakout / server lockup on resume with intel driver (i915)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 17:34 EDT by Will Woods
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 10:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from X lockup (41.55 KB, text/plain)
2007-05-02 17:34 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2007-05-02 17:34:05 EDT
xorg-x11-server-Xorg-1.3.0.0-3.fc7
xorg-x11-drv-i810-2.0.0-2.fc7

When I resume from suspend, X freaks out - it looks like it's going to resume,
then the screen goes all gray and the pointer locks up. Then it repeats. This
happens whether or not I am running compiz at the time.

At the end of Xorg.0.log I see:

Error in I830WaitLpRing(), now is 1319358529, start is 1319356528
pgetbl_ctl: 0x1ffc0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 0
LP ring tail: 8e8 head: 0 len: 1f001 start 0
eir: 0 esr: 1 emr: ffff
instdone: ffc1 instpm: 0
memmode: 306 instps: 2014c0
hwstam: fffe ier: a2 imr: 8 iir: 0
space: 128784 wanted 131064
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xe02d6000 at 0xb7f25000

Fatal server error:
lockup
Comment 1 Will Woods 2007-05-02 17:34:05 EDT
Created attachment 153995 [details]
log from X lockup
Comment 2 Will Woods 2007-05-02 18:42:30 EDT
As an added note, this works fine in F7t4:
xorg-x11-server-Xorg-1.2.99.905-5.fc7
xorg-x11-drv-i810-1.6.5-19.fc7

Running from an F7t4 liveCD, I upgraded both components, restarted X, and..
strangely, everything works OK. Until I upgrade hal.

So maybe the post-t4 hal messed with the way resume is done on intel chips?
Nevertheless, that sort of thing probably shouldn't cause X lockups.
Comment 3 Will Woods 2007-05-02 18:50:36 EDT
Filed a different bug about the change in hal resume behavior (bug 238792).
Removing this bug from Blocker list.
Comment 4 Jesse Barnes 2008-01-10 17:18:58 EST
Does this still happen in rawhide?  The latest kernels include some 
suspend/resume code for intel chips, and the driver has had several fixes for 
suspend/resume & VT switch problems, so hopefully things work for you now.
Comment 5 Will Woods 2008-01-30 10:47:12 EST
Suspend/resume in rawhide is just fine these days. Closing.

Note You need to log in before you can comment on or make changes to this bug.