Bug 238787 - lm_sensors-devel depends on %{version} but not on %{version}-%{release}
lm_sensors-devel depends on %{version} but not on %{version}-%{release}
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 18:34 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 17:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-05-02 18:34:02 EDT
Description of problem:
lm_sensors-devel depends on %{version} but not on %{version}-%{release}, please 
fix this with the next build of the package. There can be minor changes which 
could be incompatible after release bumping, so it's save to add %{release}, 
too.

Version-Release number of selected component (if applicable):
lm_sensors-2.10.3-2

Expected results:
Please apply the following patch or better:

--- snipp ---
--- lm_sensors.spec       2007-05-03 00:32:29.000000000 +0200
+++ lm_sensors.spec.rsc   2007-05-03 00:32:36.000000000 +0200
@@ -33,7 +33,7 @@
 %package devel
 Summary: Development files for programs which will use lm_sensors.
 Group: Development/System
-Requires: lm_sensors = %{version}
+Requires: lm_sensors = %{version}-%{release}

 %description devel
 The lm_sensors-devel package includes a header files and libraries for use
--- snapp ---
Comment 1 Hans de Goede 2007-07-10 17:33:38 EDT
Hi,

Short introduction, I'm a Fedora contributer and since I'm involved in
lm_sensors upstream, I've also become a co-maintainer of lm_sensors in Fedora.

I've just build lm_sensors-2.10.3-3.fc8 for rawhide / devel, which fixes this. 

Note You need to log in before you can comment on or make changes to this bug.