Bug 238825 - cursor movement is constrained
Summary: cursor movement is constrained
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 454948
TreeView+ depends on / blocked
 
Reported: 2007-05-03 07:24 UTC by Jens Petersen
Modified: 2008-07-10 23:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 21:24:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-05-03 07:24:54 UTC
Description of problem:
When using virtual graphical consoles after the pointer is grabbed
often the cursor is constrained away from one edges of the screen,
which is annoying.

Steps to Reproduce:
1. start virtual machine from virt-manager
2. click to stay in window
3. move cursor around
  
Actual results:
Usually some part (edge) of the screen can't be reached without moving
first to the opposite edge.

Expected results:
Pointer to be directly movable to any part of screen.

Additional info:
This does not seem to happen if one runs qemu directly for instance.

Comment 1 Bryan Christ 2007-06-29 15:39:35 UTC
I have this problem too.  I've noticed that by moving the mouse really fast, it
is possible to "break through" the artificial barrier.

Comment 2 Ville Skyttä 2007-07-01 14:44:36 UTC
Same effects observed here, and the trick in comment #1 also works around it for
me (by moving really fast to the opposite direction from the constrained edge).
 The workaround isn't enough to make the machines actually usable though, it has
to be done all the time.  Tested only with a QEMU VM, F-7 x86_64.  Plain QEMU
works fine.

Comment 3 Jens Petersen 2007-07-02 02:02:58 UTC
I haven't tried "moving really fast" but for me moving to the opposite
edge and then returning clears the constraint for me.  Yes it is very annoying.

Comment 4 Red Hat Bugzilla 2007-07-25 02:10:24 UTC
change QA contact

Comment 5 Daniel Berrange 2007-09-27 21:11:45 UTC
This should be much improved in current (F8) rawhide version, since we have
re-written the VNC widget used for the console. Please let me know if it still
gets 'stuck' on invisible walls with virt-manager 0.5.1 or later.


Comment 6 Jens Petersen 2007-10-16 00:58:05 UTC
Thanks - looks good to me now. :)

Comment 7 Bryan Christ 2008-07-10 19:01:05 UTC
This problem has resurfaced with F9 and latest stable updates via yum.

Comment 8 Daniel Berrange 2008-07-10 21:24:04 UTC
Do *NOT* re-open old bugs. Please file a new bug and if relevant add a comment
refering to the original bug.


Comment 9 Jens Petersen 2008-07-10 23:08:31 UTC
Yes thanks for bringing this up - it has been back for too long. :-/

Comment 10 Jens Petersen 2008-07-10 23:18:14 UTC
(In reply to comment #8)
> Do *NOT* re-open old bugs. Please file a new bug and if relevant add a comment
> refering to the original bug.

Shrug - not sure how opening a new bug helps here - it is exactly the same
issue... -
I cloned to bug 454948 anyway. :)


Note You need to log in before you can comment on or make changes to this bug.