Bug 238837 - compiz sometimes freeze
compiz sometimes freeze
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 06:16 EDT by Adam Tkac
Modified: 2013-04-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 13:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2007-05-03 06:16:20 EDT
Description of problem:
I started using compiz about 2 weeks ago and about once a three days compiz
freeze and my computer gets completely unusable

Version-Release number of selected component (if applicable):
rpm -q compiz
compiz-0.3.6-8.fc7

How reproducible:
sometimes

Steps to Reproduce:
1. start compiz
2. wait for crash :)

Actual results:
compiz freeze my computer

Expected results:
no freezing, no crashing

Additional info:
I'm not really sure if this is a compiz bug. It could be also X or kernel bug.
But this behavior comes when I've started using compiz (I tried using devel/fc6
kernel with compiz - same result so looks like compiz/X drivers bug). Tested
only on x86_64 but could be platform-independent bug. My system is always
up2date rawhide. Any hints how get more useful debug information?

Regards, Adam
Comment 1 Thomas J. Baker 2007-05-03 16:10:37 EDT
Are you using the proprietary nvidia drivers? I updated my desktop from FC6 to
F7T4 and am experiencing similar problems. I'm running only i386 and am using
the evil nvidia proprietary drivers (dkms version from freshrpms) with two
screens. Same setup with FC6 didn't have any problems. My F7T4 laptop with intel
video doesn't have these problems so it seems to be an nvidia/compiz/kernel
problem. 
Comment 2 Adam Tkac 2007-05-04 07:39:49 EDT
(In reply to comment #1)
I blame all proprietary software :) I'm using compiz on my Mobility Radeon x700
with radeon driver (from xorg-x11-drv-ati package). So it looks like compiz bug,
not kernel or graphics drivers. I'm going to try latest development compiz (I've
created wild test package -
http://people.redhat.com/atkac/test_srpms/compiz-0.5.0-1.fc7.src.rpm :) if
problem goes away with upstream version.

-A-

Comment 3 Adam Tkac 2007-05-05 11:10:49 EDT
Next crash with 0.5.0 compiz. I'm going back to 0.3.6 :(
Comment 4 Thomas J. Baker 2007-05-09 16:09:32 EDT
I think I've experienced the same lockup now twice just using metacity. I got to
launch something from the panel, it doesn't appear, the panel get's locked, all
of gnome gets locked. It seems like maybe compiz causes the bug to happen more
often but it doesn't seem to be compiz's problem alone. I am still using the
nvidia drivers for dual monitor support though. I'm going to go searching
bugzilla for a gnome desktop lockup bug. 
Comment 5 Adam Tkac 2007-05-10 09:16:24 EDT
(In reply to comment #4)
Interesting. Sound like Xserver bug especially with X + vnc module (this also
completely hangs my computer, not reproducable with older X) Could you tell me
if you can ping/ssh into your computer when it gets freezed or it is completely
unusable.

Thanks, -A-
Comment 6 Thomas J. Baker 2007-05-10 09:21:36 EDT
It's just my gnome session that hangs. In catching up in my reading of
fedora-test-list, it appears that my problem may be one with ESD locking up. I
have desktop sounds enabled. I'm going to try reenabling compiz and when I
experience the lockup, I'm going to see if killing esd fixes it.
Comment 7 Thomas J. Baker 2007-05-11 14:26:22 EDT
My problem was definitely ESD locking up. I disabled ESD and have been running
fine for a day and a half now.
Comment 8 Adam Tkac 2007-05-12 12:04:09 EDT
(In reply to comment #7)
For me no. Compiz hanged 5 minutes ago.. I have esound disabled so my crash
isn't related to this component. Ajax, could be this X problem?

Comment 9 Adam Tkac 2007-05-21 13:46:47 EDT
Leave this one be. Compiz didn't crash about week.

-A-

Note You need to log in before you can comment on or make changes to this bug.