Bug 238845 - installer exits abnormaly during checking of dependencies
installer exits abnormaly during checking of dependencies
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-05-03 07:34 EDT by Brian
Modified: 2008-05-06 15:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 15:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anacdump file (50.86 KB, text/plain)
2007-05-03 22:38 EDT, Brian
no flags Details
error screen (1.11 MB, image/jpeg)
2007-05-03 23:02 EDT, Brian
no flags Details

  None (edit)
Description Brian 2007-05-03 07:34:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:
any install on older system that has K6-2 AMD proc and S7AX Commate motherboard with 384Mb mem and a 32Mb Nvidia Video card fails at same point, it works untill I reach the point that it starts checking dependencies , after it gets to about 5 % on the progress bar the system screen turns to non grafic mode and show it has an Python error and then shuts down the system.
The CDR I use works on 3 other systems and has NO problems and passes all media checks , it also crashes in the same way if I do a txt install.
This system has the same problem with Redhat versions after version 6 none of them install on it , tried it with RH 9 and this exits with a "hardware not supported error".
Windows 2000 and Free BSD and knoppix 5.1 Live CD run on this sytem without problems.
changed video cards and removed all ISA cards including the scsi card , no effect still crashes same point.

Version-Release number of selected component (if applicable):
ZOD final release

How reproducible:

Steps to Reproduce:
1.boot to disc 1 of Fedora core 6 leave everything on default 
2.disable IP 6 or not makes no differance
3.text or grafic mode makes no differance
4.select no packages just before it checks dependencies has no effect. 

Actual Results:
sytem shutsdown after I acknowledge and reboots.
sytem has on occasion allowed me to save dump report (only if I removed mouse)

Expected Results:
should have continued installation :)

Additional info:
screens shows this when it leaves graphical mode:
Starting grapical installation
Python:Python/getargs.c 'arg != (void *)0)' failed.
install excited abnormaly [1/1]
sending termination sigs "etc ect" and unmounting "ect ect"

then ends with "you may safely reboot your system"

I tried to install without mouse and it also crashes but gives me the oppertunity to save an error dump to a floppy (screen stays in graphic mode)
Comment 1 Jeremy Katz 2007-05-03 12:01:55 EDT
Could you try running the memory tester that's on the CD?
Comment 2 Brian 2007-05-03 22:38:38 EDT
Created attachment 154095 [details]
anacdump file
Comment 3 Brian 2007-05-03 23:02:27 EDT
Created attachment 154096 [details]
error screen

error screen
Comment 4 Brian 2007-05-03 23:08:16 EDT
checked the memory , its good.
swapped the memory anyway with other know to be good memory.
Still same problem crashes same point during install
Comment 5 Bug Zapper 2008-04-04 03:10:28 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2008-05-06 15:34:00 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.