Bug 238876 - yum-changelog doesn't appear to do anything
Summary: yum-changelog doesn't appear to do anything
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 16:05 UTC by Zack Cerza
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 1.1.5-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 20:05:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of yum session (4.82 KB, text/plain)
2007-05-03 16:05 UTC, Zack Cerza
no flags Details

Description Zack Cerza 2007-05-03 16:05:27 UTC
Description of problem:
I installed yum-changelog yesterday and tried to use it for the first time
today. It didn't seem to do anything at all (yes I did pass --changelog to yum).
Attaching log.

Version-Release number of selected component (if applicable):
yum-utils-1.1.2-1.fc7.noarch

Comment 1 Zack Cerza 2007-05-03 16:05:27 UTC
Created attachment 154045 [details]
log of yum session

Comment 2 David Kovalsky 2007-05-14 13:23:10 UTC
Tested with latest yum, problem still persists. Versions below.

[root@kovinek ~]# rpm -q yum{,-utils}
yum-3.1.7-2.fc7
yum-utils-1.1.3-1.fc7


Comment 3 Panu Matilainen 2007-05-28 10:38:41 UTC
Works for me, at least with the following versions:
[root@dhcp115 ~]# rpm -q yum yum-utils
yum-3.2.0-1.fc7
yum-utils-1.1.4-1.fc7


Looking at your yum session log, changelog does run, it's just not finding
anything to report. That can happen if a package was rebuilt (with newer
release) but changelog not updated for example. Also I think there was some
strange case where that would happen if the package was updated more than once
during a single day (has to do with how rpm stores the changelog date
information and not really fixable).

Comment 4 David Kovalsky 2007-05-28 11:32:10 UTC
It seems to work when updating one package:

[root@kovinek ~]# yum --changelog update Django
Loading "kmdl" plugin
Loading "fedorakmod" plugin
Loading "installonlyn" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Setting up Update Process
Excluding Packages from atrpms
Finished
Resolving Dependencies
--> Running transaction check
---> Package Django.noarch 1:0.96-rev5127 set to be updated
filelists.xml.gz          100% |=========================|  31 kB    00:00
--> Processing Dependency: python(abi) = 2.4 for package: Django
--> Finished Dependency Resolution

Changes in packages about to be updated:

Django - 1:0.96-rev5127.noarch, Django - 0.96-1.fc7.noarch
* Mon Apr 30 12:00:00 2007 David Kovalsky <dkovalsk@redhat.com> - 1:0.96-svnrev5127
- rebuild to the latest SVN snapshot
...

But doesn't do anything when trying to update more packages:
[root@kovinek ~]# yum --changelog update
Loading "kmdl" plugin
Loading "fedorakmod" plugin
Loading "installonlyn" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Setting up Update Process
Excluding Packages from atrpms
Finished
Resolving Dependencies
--> Running transaction check
filelists.xml.gz          100% |=========================| 182 kB    00:00
---> Package directfb.i386 0:1.0.0-14.fc6.93 set to be updated
---> Package Django.noarch 1:0.96-rev5127 set to be updated
--> Processing Dependency: libfusion-1.0.so.0 for package: directfb
--> Processing Dependency: python(abi) = 2.4 for package: Django
--> Processing Dependency: libfusion-1.0.so.0 for package: xine-lib-extras
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libfusion-1.0_0.i386 0:1.0.0-14.fc6.93 set to be updated

Changes in packages about to be updated:

Django - 0.96-1.fc7.noarch, Django - 1:0.96-rev5127.noarch
libfusion-1.0_0 - 1.0.0-14.fc6.93.i386, directfb - 1.0.0-1.fc7.i386, directfb -
1.0.0-14.fc6.93.i386

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 Django                  noarch     1:0.96-rev5127   southpark         2.0 M
 directfb                i386       1.0.0-14.fc6.93  atrpms            1.7 M
Installing for dependencies:
 libfusion-1.0_0         i386       1.0.0-14.fc6.93  atrpms             17 k

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total download size: 3.7 M
Is this ok [y/N]:

[root@kovinek ~]# rpm -q yum yum-utils
yum-3.2.0-1.fc7
yum-utils-1.1.4-1.fc7




Comment 5 Panu Matilainen 2007-05-28 12:43:48 UTC
Ahhah, got it. Either this was a very old bug gone unnoticed, or perhaps more
likely caused by a yum change causing changelog plugin to do non-obvious stupid
things :) Anyway, fixed in yum-utils cvs, will get fixed once a new version of
yum-utils is released and pushed for F7.

Comment 6 Fedora Update System 2007-06-18 16:37:44 UTC
yum-utils-1.1.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-06-21 20:04:53 UTC
yum-utils-1.1.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 David Kovalsky 2007-06-27 13:08:49 UTC
Playing with today's updates, everything works for me as expected.


Note You need to log in before you can comment on or make changes to this bug.