Bug 23891 - gcc -O3 gives internal error
gcc -O3 gives internal error
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 11:41 EST by ian.clark
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ian.clark 2001-01-12 11:41:06 EST
Compiling C code works without any optimisation options in GCC but if I
turn
on the -O3 option it gives an internal error and says to report a bug to
you.
the C code in question can be supplied to you to test if you need it.
I have a complete new install of RedHat 7.0 with all the latest upgrades
etc as of 10/1/2001. This code has run and compiled cleanly on previous
verions
of RedHat that I run, 5.0, 5.2, 6.0, 6.1.
The code in compiled form would not run sometimes on certain model files I
created
until I upgraded glibc.

Please contact me for more details
Comment 1 Jakub Jelinek 2001-01-12 11:59:43 EST
Please attach here the command you are able to reproduce this with,
plus add -save-temps -v command line options and attach here the preprocessed
source this command generates.
Comment 2 Need Real Name 2001-01-13 04:03:41 EST
I have seen the same thing.  I am able to compile with a -O but not a -O2 or -
O3.  I am sorry to say that I can not give out the code that is causing this.  
But if I can help in any other way please let me know.
Comment 3 Jakub Jelinek 2001-01-13 06:01:57 EST
If you cannot give out the source (even just privately to us without
anybody else seeing it), then basically the only thing which can be done
is that you: preprocess the source, then, if the compiler gives you
ICE on it, try to minimize it as long as it still ICEs (first find
out which only routines are needed to reproduce it, then remove
statements which have no influence on the ICE going away), once you
have a minimal testcase, I believe after changing variable names and
the like you would not break any trade secrets posting it here.
Without a testcase I really cannot do anything for that.
Comment 4 Jakub Jelinek 2001-02-23 07:56:38 EST
If you manage to create a testcase, please reopen this bug.
Comment 5 ian.clark 2001-02-26 06:52:34 EST
This is NOT resolved!

I emailed you the code over a month ago, I then got a reply from you

"On Wed, Jan 24, 2001 at 11:56:44AM +0000, Ian G. Clark ... *Sparks* wrote:
> On Tue, 23 Jan 2001, Jakub Jelinek wrote:
> 
> > On Tue, Jan 23, 2001 at 11:27:18AM +0000, Ian G. Clark ... *Sparks* wrote:
> > > HI Jakub,
> > >   Did my C code arrive with you last week? (for bugzilla bug 23891)
> > 
> > Nope. It is nothing secret, please try to use the Create a new attachment
> > HREF in bugzilla, otherwise mail it to me.
> > 
> Hi Jakub,
>       I emailed the code to you again last night, has it arrived?

Yes, I was able to reproduce it and it is in my queue (I'd like to fix first
a few bugs I have analyzed already, so it may take a few days).

        Jakub
"

And thats the last I heard about it?

What is going on?
Comment 6 Jakub Jelinek 2001-02-26 06:59:41 EST
Ouch sorry, I have it hanging here, it is some gcse failure on huge routine
which I've not debugged yet. I closed it because the fact that I have the
testcase was not mentioned here in bugzilla, so I thought I don't have it.
Comment 7 ian.clark 2001-02-26 07:21:26 EST
My apologies, I didn't mean the reply to read so sharp. I'm having a bad code
day here!
I should have emailed the code to bugzilla, but didn't really want it in the
public domain
yet.
Comment 8 Jakub Jelinek 2001-04-04 11:32:30 EDT
Sorry for the long delay. It turned out to be a bug in null pointer check
optimization, which I've fixed today, the fix will appear in gcc-2.96-81.
Comment 9 Jakub Jelinek 2001-09-06 13:03:06 EDT
Oopsie, forgot to close. It should work in 2.96-81 and above (e.g. in current
2.96-98 rechecked).
Comment 10 Bill Nottingham 2006-08-04 16:14:34 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.