Bug 238926 - MD assembly failed due to sdX device renumbering
MD assembly failed due to sdX device renumbering
Status: CLOSED DUPLICATE of bug 151653
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-05-03 17:26 EDT by Jon Burgess
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 17:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system log (33.52 KB, text/plain)
2007-05-03 17:26 EDT, Jon Burgess
no flags Details
anaconda.log (15.74 KB, text/plain)
2007-05-03 17:28 EDT, Jon Burgess
no flags Details

  None (edit)
Description Jon Burgess 2007-05-03 17:26:17 EDT
Description of problem:
While upgrading an FC6 system with F7t4 anaconda failed to locate all the
devices for the existing MD array and so could not upgrade the existing install.

This looks very much like a duplicate of:
237456: Existing LVM, Software Raid, and SATA disks not detected
I thought it made sense to open a new one to keep all my logs files and info
together.


Version-Release number of selected component (if applicable):
f7t4

How reproducible:
every time

Steps to Reproduce:
1. FC6 system with 4 SATA disks on AHCI controller as sda,sdb,sdc,sdd
2. /dev/md0 = RAID1 of sda1, sdb1, sdc1, sdd1
3. /dev/md1 = RAID5 of sda2, sdb2, sdc2, sdd2
4. Plug in USB Had disk containing f7t4-DVD.iso on filesystem
5. Plug in USB "all-in-one" card reader (which appears as 4 individual USB SCSI
disks.
6. Boot f7t4 install (from grub entry on existing install)
7. Anaconda loads usb-storage, assigns sda = USB hard disk
8. Also sd[bcde] are taken by all-in-one USB card reader
9. In anaconda, select HD install with /dev/sda1 as source. Starts OK
10. AHCI module loaded
11. The 4 installed hard disks for the MD array get assigned to sd[fghi]
12. Anaconda tries to start the MD array, finds sdf1 but fails to open or find
any of the other disks of md0
13. Ditto for md1 - finds sdf2 but no other array members.
14. MD array startup fails, anaconda finds no existing install


Actual results:
No working upgrade path :-(

I will attach the full syslog.txt which covers the MD messages etc for the
description above.


Expected results:
Should be able to start the array even though the sdX devices have changed.

Additional info:
I can make things a little better by removing the all-in-one USB device. In this
case the external USB disk gets sda, the 4 normal disks sd[bcde]. In this
scenario the array finds 3 of the 4 disk (sd[bcd] only) so manages to start up
in degraded mode allowing the install to proceed. Unfortunately there is no
indication of this in the GUI, slows down the install and takes a while to
rebuild the array afterwards.
Comment 1 Jon Burgess 2007-05-03 17:26:17 EDT
Created attachment 154076 [details]
system log
Comment 2 Jon Burgess 2007-05-03 17:28:54 EDT
Created attachment 154078 [details]
anaconda.log
Comment 3 Jarod Wilson 2007-05-15 14:19:06 EDT
Appears to be a dupe of bug 151653.
Comment 4 Will Woods 2007-05-15 17:36:49 EDT

*** This bug has been marked as a duplicate of 151653 ***

Note You need to log in before you can comment on or make changes to this bug.