Bug 238928 - Sound detection fails from time to time
Sound detection fails from time to time
Status: CLOSED DUPLICATE of bug 232217
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2007-05-03 17:57 EDT by Luc
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-22 10:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
scsconfig.log and scsrun.log when OK and when it fails (26.53 KB, application/x-gzip)
2007-05-03 17:57 EDT, Luc
no flags Details
files modeprobe.conf - modeprobe.conf.BAD - system-config-soundcard logs (13.62 KB, application/x-gzip)
2007-05-07 18:11 EDT, Luc
no flags Details

  None (edit)
Description Luc 2007-05-03 17:57:40 EDT
Description of problem:
- sometimes, KDE sound server failed to initialize and no sound is available.
If i run system-config-soundcard when it fails, pannel shows only audio
peripherals of my motheboard (ASUS-A8N-E)with no peripheral parameter. In that
case the audio peripheral of my USB webcam is not detected. The sound test
fails, and I cannot reload audio modules: system-config-soundcard asks me to reboot
- when the KDE sound server is OK, sound is OK. If I run
system-config-soundcard, I find motherboard peripherals AND the USB webcam
peripheral. In that case, there is peripheral parameter for both. BUT the sound
test still fails in spite of the fact that the sound is OK.

Version-Release number of selected component (if applicable):
Fedora 7 Test 4
system-config-soundcard 2.0.6-4.fc7
KDE  	3.5.6-6.fc7

How reproducible:
Mean failure rate: 1 time every 4 run

Steps to Reproduce:
1.launch Fedora
2. Log in KDE
3.Then an error message regarding sound server init is diplayed
Actual results:
No sound, even if I try to restart KDE or sound modules through

Expected results:
sound server OK

Additional info:
Comment 1 Luc 2007-05-03 17:57:40 EDT
Created attachment 154080 [details]
scsconfig.log and scsrun.log when OK and when it fails
Comment 2 Luc 2007-05-07 18:11:24 EDT
Created attachment 154302 [details]
files modeprobe.conf - modeprobe.conf.BAD - system-config-soundcard logs
Comment 3 Luc 2007-05-07 18:13:14 EDT
As my FC6 works fine with the same configuration, I copied the FC6
/etc/modprobe.conf in F7.
Then the sound was always OK.
Nevertheless, system-config-soundcard still gives errors from time to time.
I put a new attachement that gives the modeprobe.conf that comes from fc6 and is
OK, the modprobe.conf.BAD given by F7 and a logs from sytem-config-oundcard when
it fails.
Comment 4 Luc 2007-05-08 10:43:03 EDT
In the case where systerm-config-soundcard fails the test, if I shutdown the
sound server in the KDE control center, the test becomes OK. Then if I restart
the sound server, the test remains still OK.
Comment 5 Martin Stransky 2007-05-22 10:06:44 EDT
The problem with an USB card is a dupe if Bug 232217
Comment 6 Martin Stransky 2007-05-22 10:13:55 EDT
Please attach all your sound devices to your box, run system-config-soundcard,
switch to "System" page, select "Rewrite configuration files" and reboot your
box. All cards should be on the selected position (you can fidle with them on
"Settings" page).

*** This bug has been marked as a duplicate of 232217 ***

Note You need to log in before you can comment on or make changes to this bug.