Bug 238933 - SELinux denial on fc7 test4 i386 - while inserting smartcard
Summary: SELinux denial on fc7 test4 i386 - while inserting smartcard
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pcsc-lite   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bob Relyea
QA Contact:
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 22:52 UTC by Chandrasekar Kannan
Modified: 2015-01-04 23:26 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-2.6.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 01:38:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SELinux alert message (2.47 KB, text/plain)
2007-05-03 22:52 UTC, Chandrasekar Kannan
no flags Details

Description Chandrasekar Kannan 2007-05-03 22:52:21 UTC
Description of problem:

smartcard insertion event produces SElinux denial.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. insert smartcard
2.
3.
  
Actual results:

selinux denial.

Expected results:

ESC should be started. ESC icon should be visible on system tray.


Additional info:
see attachment for more details.

Comment 1 Chandrasekar Kannan 2007-05-03 22:52:22 UTC
Created attachment 154081 [details]
SELinux alert message

Comment 2 Jack Magne 2007-05-04 01:30:11 UTC
Dan:

As seen from the attachment, it is "pcscd" daemon that is receiving the denial.

Would you have any thoughts on this issue?

thanks,
jack

Comment 3 Daniel Walsh 2007-05-04 14:30:10 UTC
Funny you should ask,  I spent most of yesterday with my new pcmcia smartcard
reader, crashing kernels and writing policy.  So I have some fixes that will go
into rawhide as soon as the merge allows me to update.

Fixed in selinux-policy-2.6.3-1.fc7


Comment 4 Jack Magne 2007-05-04 17:29:22 UTC
Thank you very much for updating us on this!

Just a question:

1. Would you like for us to give the RPM (when ready) a quick test with our
Smart Cards and present feedback? We'd be happy to grab an RPM if it would be
useful.

thanks again,
jack

Comment 5 Daniel Walsh 2007-05-15 14:41:25 UTC
The policy should be available now.

Comment 6 Bug Zapper 2008-04-04 00:28:40 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 7 Bug Zapper 2008-05-07 01:38:50 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp


Note You need to log in before you can comment on or make changes to this bug.