This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 238971 - koji honours ExcludeArch even without bug numbers.
koji honours ExcludeArch even without bug numbers.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 05:17 EDT by David Woodhouse
Modified: 2013-01-09 20:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 15:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-05-04 05:17:25 EDT
We have rules which say you _MUST_ have a bug filed and on a given ExcludeArch
tracker in order to use ExcludeArch:. The build system should enforce this, to
help people remember.

Simply keeping track of excluded builds isn't sufficient -- when the bugs are
filed, they also give some _explanation_ of what the problem is and why the fix
is beyond the capacity of the package maintainer and needs support from an
expert for the given architecture.

Something simple like requiring bug numbers on the line before the ExcludeArch:
line in the specfile would probably be sufficient.
Comment 1 Mike McLean 2007-05-04 12:01:28 EDT
This is the only reference I can find to the policy:
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines?highlight=%28ExcludeArch%29

Is this the extent of it, or is there something more specific?

Currently Koji does not not parse the spec directly, it lets rpm handle that.
Since this policy involves a comment, we could have to rip the spec out and
parse it. This is complicated by the fact that the policy does not set a strict
format for the bug reference(s).

All this should be doable in principle, but I would feel better about things if
there was a more rigid rule for the bug reference.

Did plague enforce this?
Comment 2 Jesse Keating 2007-05-04 12:13:12 EDT
No, plague did not enforce this.  I wonder if it would make more sense at the
SCM level instead, parse the spec at check in time or what not and if no proper
comment is found...
Comment 3 Mike McLean 2007-05-04 12:32:49 EDT
Enforcing at SCM occurred to me as well. This may make more sense.
 - spec is more easily available at that point
 - developer gets the needed feedback sooner
Comment 4 David Woodhouse 2007-05-04 13:56:19 EDT
Yeah, doing it at the SCM level seems sensible.
Comment 5 Jesse Keating 2007-06-12 15:25:58 EDT
I'm closing this WONTFIX as we want this at the SCM level.

Note You need to log in before you can comment on or make changes to this bug.