Bug 238978 - Cannot connect solaris to nic using qemu
Summary: Cannot connect solaris to nic using qemu
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-04 10:14 UTC by Mike Reeves
Modified: 2008-07-15 18:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 18:02:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Reeves 2007-05-04 10:14:19 UTC
Description of problem: While installing Solaris (10) VM under the "UNIX" option
with qemu/kvm, the Virtual Manager assigns eth0 as the default nic but Solaris
expects to see rlst0 and as a result no dhcp connectivity is established for the
solaris install.


Version-Release number of selected component (if applicable):
kvm-19.2.i386
libvirt-0.2.2-2.fc7.i386
libvirt-python-0.2.2-2.fc7.i386
virt-manager-0.4.0-1.fc7.i386


How reproducible: From the Virtual Machine Manager select "new", on the next
panel enter a vm machine name then select "next or forward", then "next or
forward" and on the "Locating Installation Media Panel insert eh solaris iso dvd
into the drive and select that "CDROM or DVD" then on "OS Type" select "UNIX"
then on "OS Variant" select "Solaris 10" the select "next or forward". Select
the disk size and then "forward". On the "Connect Host to a  Network" panel the
only option that appears valid is the "Default" option of the "Virtual Network"
box. The "Shared physical device" box appears to have a line through the middle.
Select "neot or forward" until the install begins. The install proceeds normally
until the "network" configuration portion of the Solaris install which is
looking for rlst0 as opposed to eth0.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
cannot assign rlst0 as nic name.

Expected results:
should be able to assign rslt0 as nic name

Additional info:

Comment 1 Red Hat Bugzilla 2007-07-25 02:10:50 UTC
change QA contact

Comment 2 Cole Robinson 2008-03-12 20:54:22 UTC
Hi, reassigning to python-virtinst where this bug actually is (virt-manager uses
virtinst for all installing related stuff).

Comment 3 Bug Zapper 2008-05-14 02:51:22 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Cole Robinson 2008-06-12 20:45:04 UTC
So I just gave an open solaris live cd from May a spin with bridged networking,
and connectivity was fine. The issue described seems a bit strange to me anyways
since virt-install/libvirt doesn't dictate the interface name _in_the_guest, it
just gives it a nic and the guest should name it as it wants.

Have you seen this reliably on f8 or f9? The f7 stack is pretty old at this
point, particularly kvm having taken leaps and bounds. What type of networking
are you using? What is they exact error message that is coming up, and does the
install actually say anything specific about 'eth0'? Can you reproduce this with
opensolaris media or at least something I can snag for free?

Thanks

Comment 5 Cole Robinson 2008-07-15 18:02:40 UTC
Closing this since I've not been able to reproduce and have not received a
response from the reporter in over a month. Please reopen if you are still
seeing this issue.


Note You need to log in before you can comment on or make changes to this bug.