Bug 238983 - multipath callouts use incorrect command line options for dasdview
multipath callouts use incorrect command line options for dasdview
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.5
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
: OtherQA
Depends On:
Blocks: 217102 242778
  Show dependency treegraph
 
Reported: 2007-05-04 06:42 EDT by Bryn M. Reeves
Modified: 2010-10-22 10:43 EDT (History)
15 users (show)

See Also:
Fixed In Version: RHEA-2007-0808
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:16:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
change hwtable.c & config templates to use "-f <device>" (1.57 KB, patch)
2007-05-04 07:23 EDT, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2007-05-04 06:42:21 EDT
Description of problem:
Device-mapper multipath uses callouts to identify paths & priority groups. On
s390 using IBM's DASD devices this uses the dasdview command to obtain this
information.

Support for this was included in the RHEL 4.5.0 device-mapper-multipath based on
upstream work.

The dasdview command is provided in the s390-tools RPM and changed its command
line options upstream in version 1.4.0:

1.4.0:
[...]
     - dasd tools: minor enhancements, rework and harmonization of the
          commandline options


The main change here is that the "-f <device node>" option is no longer
mandatory and has been replaced by a mandatory device argument instead. i.e.:

pre-1.4.0:

# dasdview -f /dev/dasda

post-1.4.0:

# dasdview /dev/dasda

Older versions fail if the "-f" is not supplied.

RHEL5 does not have this problem as it ships with s390-tools-1.5.3; RHEL4 uses
1.3.2 and so will not work with the default multipath configuration although the
problem is easily worked around by overriding the default callouts in
multipath.conf.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-21.RHEL4.s390

How reproducible:
100%


Steps to Reproduce:
1. Configure multipath.conf on a system using dasd devices as the underlying storage
2. Run multipath

Actual results:
# multipath
 
 dasdview: usage error
 Device not specified!
 error calling out /sbin/dasdview -j /dev/dasda

Expected results:
# multipath                [ no output ]
# multipath -l -v3
load path identifiers cache
#
# all paths in cache :
#
path dasda not found in pathvec
[...]
Comment 1 Bryn M. Reeves 2007-05-04 07:23:08 EDT
Created attachment 154105 [details]
change hwtable.c & config templates to use "-f <device>"
Comment 2 Ben Marzinski 2007-05-07 14:00:16 EDT
Fix applied. Thanks.
Comment 3 RHEL Product and Program Management 2007-05-08 16:21:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 John Poelstra 2007-08-29 13:35:41 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 12 John Poelstra 2007-09-05 18:27:49 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 13 John Poelstra 2007-09-11 20:43:53 EDT
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 14 John Poelstra 2007-09-20 00:31:48 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6-Snapshot3 on partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 15 Issue Tracker 2007-09-21 09:22:38 EDT
----- Additional Comments From markver@us.ibm.com  2007-09-20 20:54 EDT
-------
I'll have to check with some real multipath devices ... but it looks like
this
is fixed on 64bit (also have to check on 31bit system when I get the
chance).

At least I no longer see the error messages:
  dasdview: usage error
  Device not specified!
  error calling out /sbin/dasdview -j /dev/dasda

Also the device section for dasd in /etc/multipath.conf seems to have the
correct syntax now:
  getuid_callout          "/sbin/dasdview -j -f /dev/%n" 


This event sent from IssueTracker by jkachuck 
 issue 119433
Comment 17 errata-xmlrpc 2007-11-15 11:16:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0808.html

Note You need to log in before you can comment on or make changes to this bug.