Bug 239007 - kernel often hangs very eary in boot
kernel often hangs very eary in boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 09:16 EDT by Thomas J. Baker
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 17:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuinfo, lspci -vv, meminfo (20.05 KB, text/plain)
2007-05-04 09:16 EDT, Thomas J. Baker
no flags Details
screenshot #1 (319.20 KB, image/jpeg)
2007-05-04 09:17 EDT, Thomas J. Baker
no flags Details
screenshot #2 (311.62 KB, image/jpeg)
2007-05-04 09:17 EDT, Thomas J. Baker
no flags Details
screenshot #3 (296.45 KB, image/jpeg)
2007-05-04 09:18 EDT, Thomas J. Baker
no flags Details
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted). (419.84 KB, image/jpeg)
2007-05-29 02:42 EDT, Eugene Teo (Security Response)
no flags Details

  None (edit)
Description Thomas J. Baker 2007-05-04 09:16:11 EDT
My laptop running current rawhide hangs quite frequently at boot. I've got three
screen shots of the hangs but I'm not sure how useful they'll be. It's the same
hang but the screen output is different in each case. I tried to show all cases
I've seen and the screen output is usually one of these three. The current
2.6.21-1.3125.fc7 kernel also doesn't power down at shutdown. This has been
happening for the past 5 to 10 kernels or so (tough to estimate) but I didn't
think of camera phone screen shots as a way of submitting a bug until now.

I've included cpuinfo, lspci -vv, meminfo.
Comment 1 Thomas J. Baker 2007-05-04 09:16:11 EDT
Created attachment 154116 [details]
cpuinfo, lspci -vv, meminfo
Comment 2 Thomas J. Baker 2007-05-04 09:17:10 EDT
Created attachment 154117 [details]
screenshot #1
Comment 3 Thomas J. Baker 2007-05-04 09:17:51 EDT
Created attachment 154118 [details]
screenshot #2
Comment 4 Thomas J. Baker 2007-05-04 09:18:27 EDT
Created attachment 154119 [details]
screenshot #3
Comment 5 Thomas J. Baker 2007-05-04 09:21:17 EDT
OK so it seems like it may have something to do with switching to high
resolution mode with the CPUs?
Comment 6 Chuck Ebbert 2007-05-04 14:51:15 EDT
Please test kernel 1.2932, which had a set of timer patches applied.
Comment 7 Thomas J. Baker 2007-05-04 16:04:35 EDT
I've rebooted with the 3132 kernel five times and it's worked all five times so
I think that it's fixed. I am still having a problem I half mentioned where if I
log in to a full user session, possibly because of compiz, the system will then
not shutdown or reboot. If I don't login, it seems to work fine but if I do, it
hangs with the last message being "Power Down" on shutdown or "Restarting
system" on restart. Should I open a different but for that?
Comment 8 Thomas J. Baker 2007-05-06 11:23:34 EDT
Does the 3141 kernel have the changes from 3132 backed out? 3132 seems to boot
consistently fine but the problems are back with the 3141 kernel. I also had
some problems with 3141 - wireless stopped working, the keyboard stopped
working, and I couldn't shutdown or reboot the laptop at all. I had to just push
the power button. I really couldn't get any more information on what happened
due to no network or keyboard.
Comment 9 Thomas J. Baker 2007-05-08 10:05:16 EDT
I'm still getting this with the 3142 kernel as well. It will quite often take
three times to successfully boot.
Comment 10 Thomas Gleixner 2007-05-15 16:32:01 EDT
can you try to add the following three kernel command line option variants ?

1: highres=off nohz=off
2: highres=off
3: nohz=off

Thanks,

     tglx
Comment 11 Eugene Teo (Security Response) 2007-05-26 22:21:44 EDT
I'm experiencing a similar problem on my new D620 too. When using kernel 1.3104,
it usually hangs at "Starting udev". I didn't have much issues with kernel
1.3149. It booted *most* of the time. Then when I started using kernel 1.3194,
it hangs at "Uncompressing Linux... Ok, booting the kernel." all the time,
unless I use nohz=off.

Let me know how I can help to narrow down this problem.
Comment 12 Douglas Furlong 2007-05-27 18:11:35 EDT
Hello All

Just too add my voice to the mix.

I've just installed F7 RC2, and I've run in to this problem as well.

booting with either of the following appended to the kernel gets my system up.

highres=off nohz=off or nohz=off

Booting with just highres=off results in a hang (almost identicle to the screen
shots previously attached).

Here is the hardware on the laptop
http://smolt.fedoraproject.org/show?UUID=12df2cc3-ec44-4abf-a01e-c90e1ad9d1ad

Let me know if any more info is required.
Comment 13 Dave Jones 2007-05-29 01:48:02 EDT
Please try build 3208 from
http://people.redhat.com/davej/kernels/Fedora/fc7/
Comment 14 Eugene Teo (Security Response) 2007-05-29 02:39:52 EDT
Dave,

I tried build 3208. It did not boot with or without nohz=off. It appeared to be
unresponsive when it's at "Uncompressing Linux... Ok, booting the kernel."

Eugene
Comment 15 Eugene Teo (Security Response) 2007-05-29 02:42:12 EDT
Created attachment 155576 [details]
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted).
Comment 16 Eugene Teo (Security Response) 2007-05-29 02:43:19 EDT
When I was using build 3194 just now, a warning and backtrace appeared on the
console. Not sure if it is related to this bug but please see the attached
screenshot (comment #15). Thanks.
Comment 17 Thomas J. Baker 2007-05-29 10:33:05 EDT
I'm still seeing the hang after switching to high resolution mode with the 3208
kernel. Often takes four or five boots to get past it but it does work sometimes.
Comment 18 Thomas J. Baker 2007-05-29 15:23:52 EDT
Another observation: with the power plugged in, my laptop hung after the high
resolution mode was set 8 times in a row. I unplugged it and it booted the first
time. I know it has hung before when unplugged but it seems to hang more plugged in.
Comment 19 Thomas J. Baker 2007-05-31 14:23:42 EDT
Just installed F7 from DVD and unfortunately, the only way I could get my laptop
to boot was with highres=off nohz=off on the command line. Due to this bug being
intermittent and me wanting to have iwlwifi work, I believe I didn't test the
3194 kernel very long, if at all. I think a 3197 one was out via koji or Dave's
repo before I ever got 3194 installed (due to slow syncing of my mirror). I hope
this bug doesn't bite too many people. 

Now off to find the bug about lvm root labeling not working correctly. As soon
as I got past this bug, my laptop still wouldn't boot because it couldn't find root.
Comment 20 Douglas Furlong 2007-06-14 05:07:03 EDT
I am now running with kernel-2.6.21-1.3228.fc7, I no longer nead either nohz=off
or highres=off the system boots as I would expect with out any additional parameter.

I would assume this bug can now be closed.
Comment 21 Thomas J. Baker 2007-06-18 15:19:51 EDT
I still get hangs with the 3228 kernel. I don't seem to be able to boot at all
with the power plugged in. It boots relatively reliably on battery but if it's
on the charger, it's <10% success. Dell Inspiron XPS M1210 with A07 BIOS.
Comment 22 Thomas J. Baker 2007-07-25 19:47:15 EDT
The 2.6.22 kernels seem to have fixed this for me. I haven't had any problems
booting on or off the charger. I've had some other bumps with the 6.2.22 kernels
(iwlwifi, usb) but it seems that the -33 version fixes everything. I won't close
this as others may still be having the problem but I'm good. Thanks!

Note You need to log in before you can comment on or make changes to this bug.