Bug 239035 - Toshiba Satellite A105 broken suspend/hibernate
Summary: Toshiba Satellite A105 broken suspend/hibernate
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-04 15:36 UTC by Jeff Guerdat
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.6.21-1.3167
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 11:17:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Guerdat 2007-05-04 15:36:07 UTC
Description of problem:
Fresh load of FC7T4 on Toshiba Satellite A105-S2716.  If I choose suspend or
hibernate, I get a message of stopping jobs and then a frozen cursor, requiring
hard power off.  All updates have been applied.  BIOS has been updated to latest
(2.0) but tried reverting back to previous version (1.8) with same results.

FC6 worked fine.

Version-Release number of selected component (if applicable):


How reproducible:
Every damned time.

Steps to Reproduce:
1.Select suspend or hibernate.
2.
3.
  
Actual results:
Frozen computer

Expected results:
Correct suspend

Additional info:
Not sure what logs, etc. you might need - please advise

Comment 1 Phil Knirsch 2007-05-16 12:53:49 UTC
Same as with #239038, i strongly suspect it's a kernel bug, so try booting with
a FC6 kernel and see if that works.

Reassigning also to kernel.

Read ya, Phil

Comment 2 Jeff Guerdat 2007-05-16 17:40:40 UTC
Installed the last FC6 kernel (2.6.20-1.2944.fc6) that worked for me in FC6 - no
joy.  All goes well until time to power off.  The text cursor freezes and that's
all she wrote.

Comment 3 Jeff Guerdat 2007-05-21 14:07:02 UTC
Update with kernel 2.6.21-1.3167 - suspend now gets past "Stopping jobs" and now
freezes at "Suspending console(s)"

Comment 4 Jeff Guerdat 2007-05-24 10:36:44 UTC
Following an unrelated suggestion on the fedora-test-list, I looked at
http://people.freedesktop.org/~hughsient/quirk/ which suggested using the Intel
video driver vs. the i810.  I was using i810 to enable TV out since that worked
well under FC6.  Using the Intel driver solves the suspend/hibernate and
shutdown power-off issues while screwing up the TV out.

Comment 5 Richard Hughes 2007-05-24 10:46:34 UTC
Okay, cool. Could you file a new bug agaist the intel driver for the tvout, and
I'll close this one as suspend is now working. Thanks.

Comment 6 Nigel Cunningham 2007-06-12 11:17:51 UTC
Closing as per previous comments.


Note You need to log in before you can comment on or make changes to this bug.