Bug 239041 - strace causes kernel error: idr_remove called for id=0 which is not allocated
strace causes kernel error: idr_remove called for id=0 which is not allocated
Status: CLOSED DUPLICATE of bug 230500
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2007-05-04 12:06 EDT by Robert Hancock
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-11 17:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Hancock 2007-05-04 12:06:40 EDT
Description of problem:

Saw an error show up in the dmesg log after I had been doing some strace runs on
various processes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Strace a process (unsure of the circumstances)
Actual results:

Saw this kernel error in dmesg:

idr_remove called for id=0 which is not allocated.

Call Trace:
 [<ffffffff8013b97d>] idr_remove+0xe0/0x14d
 [<ffffffff8018698d>] release_dev+0x65d/0x67b
 [<ffffffff80051314>] tty_release+0x11/0x1a
 [<ffffffff80012281>] __fput+0xae/0x198
 [<ffffffff80023647>] filp_close+0x5c/0x64
 [<ffffffff8001d5cd>] sys_close+0x88/0xa2
 [<ffffffff8005b2c1>] tracesys+0xd1/0xdc

Expected results:
No error

Additional info:
Comment 1 Ernie Petrides 2007-09-11 17:03:45 EDT
I believe this is one of the possible symptoms of the bug in init_dev()
that was fixed in 2.6.18-19.el5 with the following patch tracking file:


If the problem still occurs with the current RHEL5.1 beta kernel,
please reopen this bug report.

Note to DonZ: that patch tracking file should list bug 230500 in the
header (instead of RHEL4 bug 214188).

*** This bug has been marked as a duplicate of 230500 ***

Note You need to log in before you can comment on or make changes to this bug.