Bug 239042 - anaconda not attempting to load any drivers before trying to install
anaconda not attempting to load any drivers before trying to install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Regression
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-05-04 12:08 EDT by Doug Chapman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 15:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-05-04 12:08:29 EDT
Description of problem:
I booted the anaconda installer over the network on a couple of my ia64 systems.
 Once /sbin/loader starts I immediatly get an error saying it cannot download
the kickstart file.  I do not see it attempting to load any device drivers.

If I try booting with no boot arguments (i.e. try manual install instead of
kickstart) after I select "NFS directory" for the install source it asks me to
select a driver (similar to what would be seen if I had booted with nostorage).


Version-Release number of selected component (if applicable):
rawhide-20070501
anaconda-11.2.0.57-1

How reproducible:
100% on 2 different machines

Steps to Reproduce:
1. network install of rawhide
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2007-05-04 12:12:34 EDT
one more interesting bit of info...

I went to the driver selection screen and selected the e1000 driver for my
system.  It does not load the driver and comes back with this error:

Unable to find any devices of the type
needed for this installation type.

I tried this on another one of my systems that has e100 and tg3 drivers. 
Selecting those drivers has the same result.

Comment 2 Prarit Bhargava 2007-05-04 12:20:37 EDT
Doug, does this happen only on ia64?

P.
Comment 3 Doug Chapman 2007-05-04 14:20:33 EDT
(In reply to comment #2)
> Doug, does this happen only on ia64?
> 
> P.

It appears to be either ia64 specific or at least specific to the rx4640/rx2600
low end HP systems.  I tried my dl585 with the i386 install (appears that x86_64
did not get completely built) and that worked OK.

Comment 4 Jeremy Katz 2007-05-04 22:02:23 EDT
Are you sure you're using a properly matched kernel/initrd pair?  Since if not,
the module versions won't match and modules won't load properly
Comment 5 Doug Chapman 2007-05-07 11:42:44 EDT
It appears all of the rawhide trees are gone from bigpapi so I cannot try again
to see if I was somehow using a mismatched kernel/initrd.  I will leave this as
needinfo and retest when another tree is built.
Comment 6 Doug Chapman 2007-05-07 11:52:44 EDT
setting back to needinfo so I don't forget this one.
Comment 7 Red Hat Bugzilla 2007-06-11 23:51:32 EDT
requested by Jams Antill
Comment 8 Doug Chapman 2007-09-18 15:35:49 EDT
no longer seeing this in F8-test 1.

Note You need to log in before you can comment on or make changes to this bug.