Bug 239065 - dwarf location list for inlined instance parameters
dwarf location list for inlined instance parameters
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 391501 223613 230784 253156 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2007-05-04 14:08 EDT by Frank Ch. Eigler
Modified: 2010-10-22 10:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
SystemTap currently uses GCC to probe user-space events. GCC is, however, unable to provide debuggers with precise location list information for parameters. In some cases, GCC also fails to provide visibility on some parameters. As a consequence, SystemTap scripts that probe user-space may return inaccurate readings.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 05:27:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2007-05-04 14:08:37 EDT
Description of problem:

GCC does a poor job at emitting location list information for parameters to
inlined function instances.  This, coupled with gcc's greater propensity to
inline functions, is seriously limiting the visibility of those values to
debuggers and to systemtap.

Version-Release number of selected component (if applicable):
4.1

How reproducible:
Common.  Any kernel function that's static and has a single caller is now
tending to be inlined.  This renders its parameters invisible.  There are
many many cases.

See also:
http://gcc.gnu.org/PR23551
http://sources.redhat.com/PR1155
Comment 1 RHEL Product and Program Management 2007-05-04 14:24:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2007-09-07 15:54:15 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 5 Frank Ch. Eigler 2008-04-29 13:19:36 EDT
ASAP.
Comment 6 David Mair 2008-05-20 20:42:26 EDT
This should ahve been nominated for 5.2.z. I could swear I had done that
already.  This important since GSS/Eng. will rely upon STap for troubleshooting,
etc.
Comment 9 RHEL Product and Program Management 2008-06-02 16:37:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Jakub Jelinek 2008-07-09 05:25:29 EDT
I'm afraid any substantial improvement is only possible with Alex code, which
isn't even in 4.4 yet, and is definitely not backportable to 4.1 nor 4.3.
Comment 11 RHEL Product and Program Management 2008-07-09 05:27:24 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 12 Don Domingo 2008-11-06 23:54:02 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
SystemTap currently uses GCC to probe user-space events. GCC is, however, unable to provide debuggers with precise location list information for parameters. In some cases, GCC also fails to provide visibility on some parameters. As a consequence, SystemTap scripts that probe user-space may return inaccurate readings.

Note You need to log in before you can comment on or make changes to this bug.