Bug 23907 - Repeatable oops
Repeatable oops
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 14:58 EST by mike
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike 2001-01-12 14:58:49 EST
Hi.  This system is a P3 866, Asus CUV4x, RH7 (fully up2date)

The oops is triggered by using the sound input (UCL rat).  The period of
time between rat use and oops has been between 30min and 3hours.  Since the
RH7 via686a sound driver is buggered (bugzilla 18026), I'm using ALSA
drivers which seem to work well for ordinary output.

The log contains the following messages at the same time, just before the oops:
Jan 10 20:10:00 kitchenstadium CROND[9788]: (root) CMD (   /sbin/rmmod -as)
Jan 10 20:10:00 kitchenstadium kernel: Sound device 4099 went missing!

I hope I haven't forgotten anything important...
mike.




Here is the ksymoops output:

Jan 10 20:10:00 kitchenstadium kernel: Unable to handle kernel paging
request at virtual address 8b535653
Jan 10 20:10:00 kitchenstadium kernel: current->tss.cr3 = 04027000, %%cr3 =
04027000
Jan 10 20:10:00 kitchenstadium kernel: *pde = 00000000
Jan 10 20:10:00 kitchenstadium kernel: Oops: 0000
Jan 10 20:10:00 kitchenstadium kernel: CPU:    0
Jan 10 20:10:00 kitchenstadium kernel: EIP:
0010:[3c59x:__insmod_3c59x_O/lib/modules/2.2.16-22/net/3c59x.o_M39A2E91+-194365/96]
Jan 10 20:10:00 kitchenstadium kernel: EFLAGS: 00010297
Jan 10 20:10:00 kitchenstadium kernel: eax: 00001800   ebx: 80000100   ecx:
c80318a0   edx: 8b535653
Jan 10 20:10:00 kitchenstadium kernel: esi: 00000000   edi: cd17af10   ebp:
bfffeda8   esp: c14d9f50
Jan 10 20:10:00 kitchenstadium kernel: ds: 0018   es: 0018   ss: 0018
Jan 10 20:10:00 kitchenstadium kernel: Process rmmod (pid: 1881, process
nr: 60, stackpage=c14d9000)
Jan 10 20:10:00 kitchenstadium kernel: Stack: c76ce404 c8053060 cd17a454
00000000 80000100 00000000 00000000 c804ca84
Jan 10 20:10:00 kitchenstadium kernel:        0000ffff c76ce404 cd177000
cd177000 00000001 cd17a494 cd17af10 00000001
Jan 10 20:10:00 kitchenstadium kernel:        cd17a4a5 c0116cc0 cd177000
cd172000 00000000 c0116384 cd177000 00000001
Jan 10 20:10:00 kitchenstadium kernel: Call Trace:
[3c59x:__insmod_3c59x_O/lib/modules/2.2.16-22/net/3c59x.o_M39A2E91+-28576/96]
[3c59x:__insmod_3c59x_O/lib/modules/2.2.16-22/net/3c59x.o_M39A2E91+-54652/96]
[free_module+32/148] [sys_delete_module+404/464] [system_call+52/56]
Jan 10 20:10:00 kitchenstadium kernel: Code: 8b 02 29 05 c8 18 03 c8 52 e8
87 6e 0f f8 83 c4 04 c3 8d 76
Using defaults from ksymoops -t elf32-i386 -a i386

Code;  00000000 Before first symbol
00000000 <_EIP>:
Code;  00000000 Before first symbol
   0:   8b 02                     mov    (%edx),%eax
Code;  00000002 Before first symbol
   2:   29 05 c8 18 03 c8         sub    %eax,0xc80318c8
Code;  00000008 Before first symbol
   8:   52                        push   %edx
Code;  00000009 Before first symbol
   9:   e8 87 6e 0f f8            call   f80f6e95 <_EIP+0xf80f6e95>
f80f6e95 <END_OF_CODE+2ffe31d6/???
Code;  0000000e Before first symbol
   e:   83 c4 04                  add    $0x4,%esp
Code;  00000011 Before first symbol
  11:   c3     ret
Code;  00000012 Before first symbol
  12:   8d 76 00                  lea    0x0(%esi),%esi
Comment 1 Arjan van de Ven 2001-01-15 07:01:33 EST
This looks like the alsa-drivers handle their usage-count incorrectly, or cannot
handle
being unloaded.

If you do a "rm /etc/cron.d/kmod ; service cron restart" as root, auto-unloading
is disabled,
and the problem should no longer occur.

Note You need to log in before you can comment on or make changes to this bug.