Bug 239078 - need to %ifarch some subpackages
need to %ifarch some subpackages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
Depends On: 238950 239077
Blocks: FE-ExcludeArch-ppc64 239132
  Show dependency treegraph
 
Reported: 2007-05-04 15:21 EDT by Bill Nottingham
Modified: 2014-03-16 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 21:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-05-04 15:21:10 EDT
Description of problem:

Neither mono (bug 238950) nor ocaml (bug 239077) can exist on ppc64. Ergo, these
subpackages need %ifarched.

Version-Release number of selected component (if applicable):

graphviz-2.12-6.fc7

How reproducible:

Every time

Steps to Reproduce:
1. Try to build.
2.
3. Profit!
  
Actual results:

Oops, no mono or caml. Build fails.

Additional info:
Comment 1 David Woodhouse 2007-05-04 16:22:37 EDT
The Gentoo folks seem to have ppc64 support for ocaml.
Comment 2 Jima 2007-05-05 22:38:27 EDT
As David knows, there's an ongoing effort (with his help) to get ocaml working
on ppc64.  I'm not aware of a similar effort for mono, unfortunately.  As a
result, I've disabled the -ocaml and -sharp subpackages, and built 2.12-7.fc7,
which I've requested RelEng include in Fedora 7.  I'll happily re-enable -ocaml
(and -sharp) if/when the BRs are available for ppc64.

I'll update this bug when I hear a final word from RelEng.
Comment 3 Jeremy Katz 2007-05-21 21:39:30 EDT
This got tagged

Note You need to log in before you can comment on or make changes to this bug.