Bug 239122 - Realtek ALC882M: No sound
Summary: Realtek ALC882M: No sound
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: sndconfig
Version: 7
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-05 04:35 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-06-26 15:05:36 UTC


Attachments (Terms of Use)
scsconfig.log (58.18 KB, text/plain)
2007-05-05 04:35 UTC, Need Real Name
no flags Details

Description Need Real Name 2007-05-05 04:35:20 UTC
Description of problem:
I have Realtek ALC882M High-Definition Audio,which is not detected and don't
hear and sound.  Tried test sounds(System->Preferences->Sound) but no sound
heard what so ever.

Version-Release number of selected component (if applicable):
Realtek ALC882M High-Definition Audio

How reproducible:
Have a system with Realtek ALC882M High-Definition Audio

Steps to Reproduce:
1. Realtek ALC882M High-Definition Audio does not detect properly
2. No sounds or test sounds.
3.
  
Actual results:
No Sound

Expected results:
Sound expected.

Additional info:  
scsconfig.log created by the sound system is attached

Contents of scsrun.log

------- System Config Soundcard Log --------
Fri May  4 21:04:16 PDT 2007

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo
cat: /etc/asound.conf: No such file or directory
cat: /etc/asound.conf: No such file or directory

Comment 1 Need Real Name 2007-05-05 04:35:20 UTC
Created attachment 154188 [details]
scsconfig.log

Comment 2 Martin Stransky 2007-05-09 11:43:13 UTC
Hm, log looks sane and I don't see any problem there. You have conected two
cards, intel and USB. Try to run system-config-soundcard and set the default card.

Comment 3 Need Real Name 2007-05-09 14:50:52 UTC
Looks like I had PCI headphone attached.  Now I removed that and my default is
Realtek ALC882M.  Still no sound.  system-config-soundcard shows me only device
which is "Corporation 82801(ICH7 Family) High Definition Audio Controller".

alsamixergui gives me an error "alsamixer: function snd_ctl_open open failed for
default: No such device or address".

Also posted my hardware profile(2c5b662b-a39a-43d6-b450-8c420897696f).

How can reinitilize all soundcard configuration ?


Comment 4 Martin Stransky 2007-05-16 09:05:25 UTC
Realtek ALC882M is the "Corporation 82801(ICH7 Family) High Definition Audio
Controller", right? 

Please try to write these lines to /etc/asound.conf:

#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

It sets the defaults to the first card (you can check your sound devices by
"aplay -l")

Comment 5 Need Real Name 2007-05-16 22:28:38 UTC
It seems to work after trying similar approach mentioned at:
http://www.linuxquestions.org/questions/showthread.php?p=2748075#post2748075

Now the volume is so low, by putting max on system control and amplifier I can
barely hear. I am yet to try /etc/modprobe.conf modification. But is there any
other way to increase the volume ?

BTW, "Corporation 82801(ICH7 Family) High Definition Audio Controller" is correct.

Thanks and appreciate your help.

Comment 6 Martin Stransky 2007-05-17 10:02:47 UTC
You can check the alsamixer utility but not sure if it helps you...

Comment 7 Need Real Name 2007-05-22 19:01:46 UTC
I checked the alsamixergui, but it did not help increasing volume.


Comment 8 Martin Stransky 2007-06-11 11:49:11 UTC
Please report it to upstream (www.alsa-project.org), they're authors of linux
sound system. And you can check the latest drivers (1.0.14), they're available
there, too.

Comment 9 Need Real Name 2007-06-21 05:40:12 UTC
I have update to Fedora 7 and issue starts with no sound.  Did not try further
at this time.  Will update when I try it again.

Comment 10 Martin Stransky 2007-06-26 15:05:36 UTC
Please check the new driver/packages (1.0.14 final). How-to is here:
http://people.redhat.com/stransky/alsa/

Anyway, Please report it to upstream (www.alsa-project.org) if the updated
drivers doesn't help to you.



Note You need to log in before you can comment on or make changes to this bug.