Bug 239122 - Realtek ALC882M: No sound
Realtek ALC882M: No sound
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-05 00:35 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 11:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsconfig.log (58.18 KB, text/plain)
2007-05-05 00:35 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2007-05-05 00:35:20 EDT
Description of problem:
I have Realtek ALC882M High-Definition Audio,which is not detected and don't
hear and sound.  Tried test sounds(System->Preferences->Sound) but no sound
heard what so ever.

Version-Release number of selected component (if applicable):
Realtek ALC882M High-Definition Audio

How reproducible:
Have a system with Realtek ALC882M High-Definition Audio

Steps to Reproduce:
1. Realtek ALC882M High-Definition Audio does not detect properly
2. No sounds or test sounds.
3.
  
Actual results:
No Sound

Expected results:
Sound expected.

Additional info:  
scsconfig.log created by the sound system is attached

Contents of scsrun.log

------- System Config Soundcard Log --------
Fri May  4 21:04:16 PDT 2007

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo
cat: /etc/asound.conf: No such file or directory
cat: /etc/asound.conf: No such file or directory
Comment 1 Need Real Name 2007-05-05 00:35:20 EDT
Created attachment 154188 [details]
scsconfig.log
Comment 2 Martin Stransky 2007-05-09 07:43:13 EDT
Hm, log looks sane and I don't see any problem there. You have conected two
cards, intel and USB. Try to run system-config-soundcard and set the default card.
Comment 3 Need Real Name 2007-05-09 10:50:52 EDT
Looks like I had PCI headphone attached.  Now I removed that and my default is
Realtek ALC882M.  Still no sound.  system-config-soundcard shows me only device
which is "Corporation 82801(ICH7 Family) High Definition Audio Controller".

alsamixergui gives me an error "alsamixer: function snd_ctl_open open failed for
default: No such device or address".

Also posted my hardware profile(2c5b662b-a39a-43d6-b450-8c420897696f).

How can reinitilize all soundcard configuration ?
Comment 4 Martin Stransky 2007-05-16 05:05:25 EDT
Realtek ALC882M is the "Corporation 82801(ICH7 Family) High Definition Audio
Controller", right? 

Please try to write these lines to /etc/asound.conf:

#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

It sets the defaults to the first card (you can check your sound devices by
"aplay -l")
Comment 5 Need Real Name 2007-05-16 18:28:38 EDT
It seems to work after trying similar approach mentioned at:
http://www.linuxquestions.org/questions/showthread.php?p=2748075#post2748075

Now the volume is so low, by putting max on system control and amplifier I can
barely hear. I am yet to try /etc/modprobe.conf modification. But is there any
other way to increase the volume ?

BTW, "Corporation 82801(ICH7 Family) High Definition Audio Controller" is correct.

Thanks and appreciate your help.
Comment 6 Martin Stransky 2007-05-17 06:02:47 EDT
You can check the alsamixer utility but not sure if it helps you...
Comment 7 Need Real Name 2007-05-22 15:01:46 EDT
I checked the alsamixergui, but it did not help increasing volume.
Comment 8 Martin Stransky 2007-06-11 07:49:11 EDT
Please report it to upstream (www.alsa-project.org), they're authors of linux
sound system. And you can check the latest drivers (1.0.14), they're available
there, too.
Comment 9 Need Real Name 2007-06-21 01:40:12 EDT
I have update to Fedora 7 and issue starts with no sound.  Did not try further
at this time.  Will update when I try it again.
Comment 10 Martin Stransky 2007-06-26 11:05:36 EDT
Please check the new driver/packages (1.0.14 final). How-to is here:
http://people.redhat.com/stransky/alsa/

Anyway, Please report it to upstream (www.alsa-project.org) if the updated
drivers doesn't help to you.

Note You need to log in before you can comment on or make changes to this bug.